0

I have decided my structure of permalinks from /?p=125 to /sample-page. I have tried some methods, but anyone works. I have changed the structure in settings/permalinks and I have tried with some plugin in order to get a redirecction, however I have not get anything. I don`t know what to do, because I get 404 error when I open any of my pages. I would like to know how to solve this problem, and if it has any relation with my server.

1
  • Does your server meet the requirements for pretty permalinks? ask your host if you are unsure. – Milo Feb 24 '15 at 23:50
0

When you save permalink settings, is there the following notification at the bottom of page?

If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

I'm asking because the behaviour you described may be caused by non-existing or non-writable .htaccess file in your WordPress root.

If you have a shell access to the server environment (or you work locally), you can create this file and add writing permissions:

cd your_wp_directory
touch .htaccess
chmod a+w .htaccess

After that, save permalink settings again.

1
  • I have tried, but my hosting can`t let me use the console..However, the notification that you said did not appear at the bottom of page – Sergiohernandez Feb 25 '15 at 0:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.