0

I am migrating a Wordpress blog from Bluehost to Dreamhost (the hostname of the blog is not changing). Here are the steps I followed:

  1. Exported the database via phpMyAdmin from Bluehost.
  2. Scp'ed the files from Bluehost to Dreamhost.
  3. Imported database via phpMyAdmin into new Dreamhost database.
  4. Copied files into place on Dreamhost.
  5. Updated wp-config.php to point to the new database on Dreamhost.
  6. Updated Dns records to move the hostname from Bluehost to Dreamhost. (Its been 24 hours since this step.)

Php version information: http://www.heartfishpress.com/php-version.php

The wp-admin works fine. The actual blog is WSOD (as I have learned it is called).

I turned in the debug option in wp-config.php. I was seeing the following dumped to the top of some of the pages:

Notice: get_current_theme is deprecated since version 3.4! Use wp_get_theme() instead. in /home/heartfishpress/heartfishpress.com/wp-includes/functions.php on line 3378

Notice: add_custom_image_header is deprecated since version 3.4! Use add_theme_support( 'custom-header', $args ) instead. in /home/heartfishpress/heartfishpress.com/wp-includes/functions.php on line3378

Notice: add_custom_background is deprecated since version 3.4! Use add_theme_support( 'custom-background', $args ) instead. in /home/heartfishpress/heartfishpress.com/wp-includes/functions.php on line 3378

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/heartfishpress/heartfishpress.com/wp-includes/functions.php:3378) in/home/heartfishpress/heartfishpress.com/wp-content/plugins/eshop/eshop.php on line 49

Given that these are just deprecation notices and a warning, these do not seem to be the culprit.

I then deactivated all plugins and themes by changing the names of the plugins and themes folders. I then copied the 'twentyfifteen' theme into a new themes folder and made sure that was selected in the wp-admin as the theme in use. I also confirmed that the active_plugins record in the wp_options table has a option_value of 'a:0:{}'.

For completeness, there is a list of the plugins that were active in the blog (there were others that were inactive)

  1. All In One SEO Pack
  2. Contact Form 7
  3. eShop for Wordpress
  4. Page Links To
  5. WordPress.com Stats

I confirmed that the wp_db_version in the wp_options table and version.php matched.

Still no luck.

Out of desperation I tried increasing the allotted memory to Wordpress via wp-config.php, no luck.

As you can see, I tried many of the tips that are commonly prescribed when the WSOD is experienced.

Can anyone offer any insight?

  • It is really hard to pin something like this down by looking at the front end. But I see some of the pages are partially loading, and even a few of the images, but strangely not all of them. heartfishpress.com/prints/smile-letterpress-print-in-yellow vs heartfishpress.com/online-shop – skribe Feb 22 '15 at 19:20
  • What I've resorted to is installing Wordpress via a one-click on Dreamhost, bringing over only the wp-content folder and then importing db tables one-by-one by hand. Progress is slow, but seems to be headed in the right direction. – rshepherd Feb 22 '15 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.