0

I have an unwanted empty line at the beginning of the document and I can't find the reason why it is happening. For default HTML I wouldn't have minded it but RSS doesn't work. I disabled all the plugins and no luck; the plugins don't cause anything. I started having this issue after I changed the file owner and permissions a long time ago but didn't care at the time. My permissions for all files and folders in the theme are "rwxr-xr-- myusername:www-data". I tried to add comments at the beginning of header.php, had no luck. The line exists even in /wp-admin. wp-login.php doesn't have it though. Where should I look for this line?

Thank you!

1

It is very hard to guess, the bit about permissions is peculiar.

The steps I would take to locate or at least narrow down the issue:

  1. Verify or reinstall core files
  2. Enable WP_DEBUG and see if there are related errors
  3. Dump get_included_files() and see if there are any unexpected/external files
  • I just updated my wordpress core, so I believe all the changes (if any) were reverted. I enabled WP_DEBUG and I am getting a warning "driver mismatch" because I am using MariaDB. I will work on fixing it but I have another Wordpress website on the same server and it works without the new line. So, I don't believe the issue here is the warning. I am checking get_included_files() now. – Gasim Feb 20 '15 at 14:08
  • For a test, I just switched the theme file and the line disappeared. So, at least it decreased my list to a few files – Gasim Feb 20 '15 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.