0

I have created a Xampp powered local wordpress install. This will be used at my work as a sort of "intranet" using LAN - I have no intentions of deploying it on a server, as it is not required by what we need it for.

Right now, all computers type in the IP address to the hosting computer ie. 192.168.x.xx:80/wordpress -- this works great, however, the images do not appear - I believe this is because the other computers are looking for http://localhost:80/wordpress/wp-content../img.jpg

Of course this confuses the computer because it thinks it's the localhost. Is there a way I can force the items in the media library to be relative paths? This would also have to automatically make new uploads relative as well. I know this isn't necessary desired in most circumstances, but I would need it for this one.

I have changes the site URL to the IP of the computer, but this causes the host computer to be unable to log in, and I don't want to have my co-workers have to do this each time we switch the host computer. Thanks all for looking, I appreciate any ideas or answers.

  • what do you have entered as the values for 'home' and 'siteurl' options (Settings > General)? – karpstrucking Feb 17 '15 at 20:57
  • This doesn't work because your WP siteurl is defined as localhost/wordpress instead of it's base IP. Basically, if you right click -> inspect element on any of the images, you'll see their paths are set to localhost/wordpress. I'm afraid there's no relative paths, at the moment, unfortunately but you could give this a shot: try changing your site URL to 192.168.0.1/wordpress (or whatever your IP is for localhost). – cristian.raiber Feb 17 '15 at 21:11
  • Thanks for the comments! I have changed my siteurl to the 192.168.x.xx - and it does work on the computers that aren't the host. but for some reason, it makes it so the host computer cannot login. Any ideas on why that is? – Taberkinslaw Feb 17 '15 at 21:28
  • I'm not sure about this, but I think this should be a different question. – cristian.raiber Feb 17 '15 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.