This is my first time installing a child theme and I ran into some errors

Here' the style.css

Theme Name: WD TechGoStore-child
Theme URI: http://wpdance.com/
Description: Commerce Template
Author: WPDance Team / WPDance.com
Author URI: http://wpdance.com/
Version: 1.0.3
Template: Default Template
Tags: one-column, two-columns, three-columns, left-sidebar, right-sidebar, flexible-width,         custom-menu, full-width-template, rtl-language-support, sticky-post, theme- options,                     translation-ready
License: GNU General Public License v2 or later
License URI: http://www.gnu.org/licenses/gpl-2.0.html

Here's the error:

The parent theme is missing. Please install the "Default" parent theme.

I've already tried several names for the "Template" but don't know which one should be there as my theme only uses the default template.

Any help would be appreciated.


1 Answer 1


Change this line: Template: Default Template to Template: wp_techgostore-theme-package

As per the WordPress Codex,

The Template line corresponds to the directory name of the parent theme

  • Yes. they are installed in wp-content/themes in respective folders as: "wp_techgostore-theme-package" and "wp_techgostore-theme-package-child" I'm guessing there's something wrong with the Template (?)
    – lonely boy
    Feb 16, 2015 at 13:50
  • Gotcha! It worked, thank you for that but I encountered another problem. When previewing the child theme, I went to the about page and the header is broken. Can you please check if I got the contents of my functions.php correct: ` <?php add_action( 'wp_enqueue_scripts', 'theme_enqueue_styles' ); function theme_enqueue_styles() { wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/style.css' ); }`
    – lonely boy
    Feb 16, 2015 at 13:56
  • Why are you messing around with the functions.php file ? You should leave it blank, assuming you're editing it in the child theme. What exactly are you trying to accomplish ? Feb 16, 2015 at 13:59
  • @Boyboy Please don't post code in comments, it is unreadable. This should be an edit to your question. Frankly, this seems more than a new issue which should be asked as a new question Feb 16, 2015 at 14:04
  • 1
    Just a tip on your formatting, use backticks ( on my keyboard it is under the ~ sign top left under esc) to enclose one liner codes and the {} in the editor for large code :-) (PSS!!! you now have enough reputation to post comments to ask for clarity ;-)) Feb 16, 2015 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.