0

The address of my WordPress site is something like: http://mycompany.com/personnel/myname.

The installation folder is: /www/personnel/myname.

When I change Permalink to Post name, it requires me to create an .htaccess file with the following content:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /personnel/myname/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /personnel/myname/index.php [L]
</IfModule>

I only have the write permission to the folder /personnel/myname/ and not to the root. Thus I created the required .htaccess file in there, but then obtained 404 error when accessing.

Hope somebody can help.

Thank you very much in advance!

  • Are you sure mod_rewrite is enabled on your server? – Milo Feb 6 '15 at 14:59
  • Hi @Milo. Using phpinfo() I see that mod_rewrite is one of the Loaded Modules, so it is already enabled. – Khue Feb 6 '15 at 15:17
  • is your server configured to parse .htaccess files in the directory it's in? do you get a WordPress 404, or a server 404? – Milo Feb 6 '15 at 17:52
  • Hi @Milo. Sorry for the late reply. How to know if the server is configured for that? It's a server 404 (404 Not found. The requested URL was not found on this server). Thanks. – Khue Feb 10 '15 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.