0

I am completely new to WordPress. I just installed it and wanted to change the theme of my website and I get following error:

Installing Theme: Klasik 0.7.5

Downloading install package from https://wordpress.org/themes/download/klasik.0.7.5.zip…

Unpacking the package…

Could not create directory.

I really don't know what to do from that point. My permissions are ubuntu www-data ( I am running this on lxc ). Please, please tell me what I have to do!! I tried to get wp working on Windows and everything worked. Now on Linux its just not working and I could destroy my monitor at the moment.... -.-

1 Answer 1

1

This is more server config question than WordPress.

Make sure the www-data group has write permissions in the directory you're running WordPress from. Assuming it's in /var/www/ then sudo chmod -R g+rwxs /var/www/ should do the trick.

1
  • Note that server configuration as related to WordPress is considered in scope here.
    – Rarst
    Feb 4, 2015 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.