1

I made a custom post type "Dream". Here is the code:

//Add custom post type by Akash
add_action( 'init', 'create_post_type');
function create_post_type() {   
    register_post_type( 
        'dream',
        array(
            'labels' => array(
                'name' => __( 'Dreams' ),
                'singular_name' => __( 'Dream' ) 
            ),        
            'taxonomies' => array('category', 'post_tag'),
            'capability_type' => 'post',     
            'map_meta_cap' => true,
            'hierarchical' => false,
            'rewrite' => array('slug' => 'Dreams'),
            'query_var' => false,    
            'delete_with_user' => true,
            'supports' => array( 
                'title', 'editor', 'author', 'thumbnail', 
                'excerpt', 'trackbacks', 'custom-fields', 
                'comments', 'revisions', 'post-formats' 
            ),
            'public' => true,
            'has_archive' => true
        )
    );
}

When I try to add the CPT "Dream" as Admin, it shows the featured image block to add media, but when I try to do same thing as Author, the featured image block is not shown. How do I solve this?

0

I used your code and tested the CPT with an author account.The option to add a featured image showing up just fine.

dashboard

So just a heads up that the issue is not related to that specific CPT snippet, you should look elsewhere. Maybe a functions.php cleanup, disable plugins and/or try another theme using the snippet as a plugin to narrow down the search.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.