0

I know there are already a few posts on this issue, but unfortunately none of those answers were helpful to me.

Every time I upload an image, I get an HTTP Error - that's it. Nothing more, no specific error or explanation, nothing. I am using WordPress 4.1.

I have already tried:

  • PHP 5.4 and 5.6 (default was 5.3)
  • different image sizes and types
  • different pages (all 4.1) and different hosting providers
  • without any plugins and with a default theme
  • different browsers (except IE, I'm a Mac user)
  • writing rights on upload folder

Direct input into posts over HTTP is working but in this case I have to manually resize all the images.

I suspect this is a major WordPress bug but I cannot wait for an update. I desperately need a solution because I have sites that are online for some time now and until now everything was OK. After the last update all my WordPress sites have the same error and my customers are, as expected, not very happy and neither am I.

  • 3
    What exactly happens? Do you get message that is literally "HTTP Error"? What does server logs say? – Rarst Jan 29 '15 at 20:00
  • Who is the owner of the uploads folder? Does PHP have permission to write to it? How did you do your last update (ie: update from /wp-admin/ or copy in files via SCP, FTP, etc)? – mor7ifer Jan 29 '15 at 20:06
  • @Rarst - Yes it is literally "HTTP Error". Server logs, I'll take a look. – ABoooo Jan 29 '15 at 20:10
  • @m0r7if3r - what do you mean who is the owner, I have admin rights and I already tried with 777 rights on an upload folder. Update - via wp-admin. – ABoooo Jan 29 '15 at 20:13
  • @Rarst - nothing useful in logs, only data from browser etc. – ABoooo Jan 29 '15 at 20:22
1

I've had the same problem and found it was due to the upload file size set for the server (in my case 2mb). There is another setting which escapes me at this point, but is basically a limit on the amount of space that can be used to process uploaded images...which WordPress does when it re-sizes the images on upload. Unfortunately, unless you have root access to your server you'll probably not be able to fix this issue yourself.

0

Try to Increase the Maximum Execution Time.

There is 3 different methods to increase it.

1) From wp-config.php file

Add the following to wp-config.php:

set_time_limit(300);

2) From .htaccess file

Add the following to .htaccess:

php_value max_execution_time 300

3) From php.ini file

Add the following to php.ini:

max_execution_time = 300

This method is working fine for me on Linux/Ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.