1

i've installed wp-cli today, while testing i ran into one surprising issue. on `wp core verify-checksums' the following errors showed up:

Warning: File doesn't verify against checksum: wp-includes/css/media-views.css
Warning: File doesn't verify against checksum: wp-includes/css/media-views.min.css
Warning: File doesn't verify against checksum: wp-includes/css/media-views-rtl.min.css
Warning: File doesn't verify against checksum: wp-includes/css/media-views-rtl.css
Warning: File doesn't verify against checksum: wp-includes/link-template.php
Warning: File doesn't verify against checksum: wp-includes/taxonomy.php
Warning: File doesn't verify against checksum: wp-admin/css/wp-admin-rtl.min.css
Warning: File doesn't verify against checksum: wp-admin/css/themes.css
Warning: File doesn't verify against checksum: wp-admin/css/wp-admin.min.css
Warning: File doesn't verify against checksum: wp-admin/css/themes-rtl.css
Warning: File doesn't verify against checksum: wp-admin/includes/update-core.php
Warning: File doesn't verify against checksum: wp-admin/user-edit.php
Error: WordPress install doesn't verify against checksums.

those files differ for each of my local installs of wordpress i've checked. each was installed as the basic english installation and switched to the german localization a few days or weeks later. I wonder now how to fix those differing md5 checksums. Basically i could download the 4.1 archive and just replace the wp-admin and wp-includes folders ( to save the time in contrast to single handedly exchanging only the differing files). But i wonder do i have to use the english archive or the german? Cuz i've downloaded both and did a diff and they differ:

Only in /Users/myuser/Downloads/wordpressde: liesmich.html
Files /Users/myuser/Downloads/wordpressen/wp-admin/css/themes-rtl.css and /Users/myuser/Downloads/wordpressde/wp-admin/css/themes-rtl.css differ
Files /Users/myuser/Downloads/wordpressen/wp-admin/css/themes.css and /Users/myuser/Downloads/wordpressde/wp-admin/css/themes.css differ
Files /Users/myuser/Downloads/wordpressen/wp-admin/css/wp-admin-rtl.min.css and /Users/myuser/Downloads/wordpressde/wp-admin/css/wp-admin-rtl.min.css differ
Files /Users/myuser/Downloads/wordpressen/wp-admin/css/wp-admin.min.css and /Users/myuser/Downloads/wordpressde/wp-admin/css/wp-admin.min.css differ
Files /Users/myuser/Downloads/wordpressen/wp-admin/includes/update-core.php and /Users/myuser/Downloads/wordpressde/wp-admin/includes/update-core.php differ
Files /Users/myuser/Downloads/wordpressen/wp-admin/user-edit.php and /Users/myuser/Downloads/wordpressde/wp-admin/user-edit.php differ
Files /Users/myuser/Downloads/wordpressen/wp-config-sample.php and /Users/myuser/Downloads/wordpressde/wp-config-sample.php differ
Only in /Users/myuser/Downloads/wordpressde/wp-content: languages
Files /Users/myuser/Downloads/wordpressen/wp-includes/css/media-views-rtl.css and /Users/myuser/Downloads/wordpressde/wp-includes/css/media-views-rtl.css differ
Files /Users/myuser/Downloads/wordpressen/wp-includes/css/media-views-rtl.min.css and /Users/myuser/Downloads/wordpressde/wp-includes/css/media-views-rtl.min.css differ
Files /Users/myuser/Downloads/wordpressen/wp-includes/css/media-views.css and /Users/myuser/Downloads/wordpressde/wp-includes/css/media-views.css differ
Files /Users/myuser/Downloads/wordpressen/wp-includes/css/media-views.min.css and /Users/myuser/Downloads/wordpressde/wp-includes/css/media-views.min.css differ
Files /Users/myuser/Downloads/wordpressen/wp-includes/link-template.php and /Users/myuser/Downloads/wordpressde/wp-includes/link-template.php differ
Files /Users/myuser/Downloads/wordpressen/wp-includes/taxonomy.php and /Users/myuser/Downloads/wordpressde/wp-includes/taxonomy.php differ
Files /Users/myuser/Downloads/wordpressen/wp-includes/version.php and /Users/myuser/Downloads/wordpressde/wp-includes/version.php differ

and do i have to deactivate my plugins before i replace the folders like suggested in http://codex.wordpress.org/Updating_WordPress or would activate the maintance mode be already enough?

1

My similar issue was solved with

wp core download --force --locale=de_DE
wp core verify-checksums

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.