1

I am working in a new project, and I just realized that in the page/post edit pages, I don´t have the option to set a featured image/ post thumbnail.

I have checked and Twenty Ten has thumbnails support by default ( add_theme_support( 'post-thumbnails' is in functions.php). I also tried setting the thumbnails size with set_post_thumbnail_size, but no luck.

Any ideas?

P.D: I installed this in a new server, is it possible that it has something to do with that? Are there any specific requirements to use post thumbnails?

  • 3
    maybe obvious question- have you made sure featured image is checked under the screen options tab? – Milo May 17 '11 at 17:23
  • Yes Milo, I already did, but thanks – 0al0 May 18 '11 at 8:04
0

The featured image meta box is enabled under following conditions:

if ( current_theme_supports( 'post-thumbnails', $post_type ) && post_type_supports( $post_type, 'thumbnail' )
    && ( ! is_multisite() || ( ( $mu_media_buttons = get_site_option( 'mu_media_buttons', array() ) ) && ! empty( $mu_media_buttons['image'] ) ) ) )
        add_meta_box('postimagediv', __('Featured Image'), 'post_thumbnail_meta_box', $post_type, 'side', 'low');

So check that:

  • nothing messes up theme's declaration of thumbnails support;
  • you are not using CPT with thumbnails support undeclared;
  • whatever that multisite-related stuff means, if you are using multisite (I do and I don't remember having to do anything specific for featured images).
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.