4

I have a problem with wildcard SSL and my host says they are unable to get it to work how I thought it would work.

I have bought a wildcard SSL certificate thinking that it should work nicely with subdomains on a wordpress multisite, but it doesn't. Every time a sub-domain is created I have to contact my host so they can setup a symlink for each subdomain. Any sub-domain where my host hasn't setup a symlinks, the sub-domains will display a 500 internal error whenever https is used. This surely can't be right.

I can't contact my host each time a new site is created on my multisite because anyone can create a site on my multisite, and many could create sites in one day. I have told them this but they say there isn't anything they can do except for creating symlinks for each subdomain.

So how do other popular wordpress multisites work well with https such as at wordpress.com?

But all subdomains on my hosted multisite display an internal error if https is used, unless my host creates symlinks for each new subdomain.

Is this a server problem. Does anyone have a solution for this? Would another host be able to make https work on subdomains without them having to manually create symlinks for each sub-domain ?

Any help appreciated.

  • 1
    What exactly are they symlinking?.. This does sound like your host cannot set it up properly. – Rarst Jan 14 '15 at 18:11
  • My comment wasn't as much bash on host (although it's always high possibility) as about possibilities of situation. If you are on shared plan your host might not be able to configure it within limitation of such setup. – Rarst Jan 14 '15 at 18:59
  • Thanks for your fast support Rarst. I am currently on a shared plan but I will needto upgrade to a dedicated server at some point. I'll check with them to see if a dedicated server will work without all this symlinking. I would've thought some type of server configurations would mean symlinks are not needed. Alternatively, are there any hosts where wildcard SSL works for subdomains automatically without all the symlinking, preferably with shared plans or would cloud hosting (like cloud sites such as at rackspace.com) be able to setup wildcard SSL without all the symlinking? – user3438958 Jan 14 '15 at 19:38
  • They said: "No this is not due to shared server limitations. This is due to the way of how virtual hosts for apache work that way. In order for the SSL to be working for every subdomain we have to create symbolic links which will reflect the virtual host in the apache configuration file in order for them to be properly routed to the correct directory." So I'm really confused. Is this the same with all hosting providers? – user3438958 Jan 14 '15 at 22:25
  • 2
    "In order for the SSL to be working for every subdomain we have to create symbolic links which will reflect the virtual host in the apache configuration file in order for them to be properly routed to the correct directory." - Okay, that's officially weird and sounds like they didn't set up wildcard subdomains properly (outside of SSL). You may want to try manually making subdomains and forcing the source folder to /public_html/ when you add them, vs using the wildcard subdomain (i.e. making a subdomain of *). That said, Multisite on less than a VPS is reckless and not recommended by anyone. – Ipstenu Jan 15 '15 at 2:56
6

my name is Daniel Kanchev and I work for SiteGround as a Senior Web Apps Engineer.

The described issue is pretty strange and I just configured a test WordPress Network on one SiteGround shared server. I did not face any similar issues and I used sub-domain names with a wildcard SSL certificate. Usually such issues are caused by Apache VHost misconfiguration problems. People often use the following setup (the default cPanel setup):

<VirtualHost 109.73.236.14:443>
    ServerName *.lumenco.ca
    ServerAlias *.lumenco.ca
    VirtualDocumentRoot /home/lumenco0/public_html/%1
    ServerAdmin webmaster@lumenco.ca
    UseCanonicalName Off

The problem is usually caused by the fact that both ServerName and UseCanonicalName are not properly set. The correct configuration that works with WordPress is:

<VirtualHost 109.73.236.14:443>
    ServerName lumenco.ca
    ServerAlias *.lumenco.ca
    VirtualDocumentRoot /home/lumenco0/public_html/%1
    ServerAdmin webmaster@lumenco.ca
    UseCanonicalName On

@Rarst, the issue is strange but this is something that is supported on shared servers and I've personally configured many WordPress apps on our shared hosting plans to use the same setup :)

  • 2
    Daniel, I can't thank you enough. After all the support ticket discussions, they finally got it working due to the server configurations you provided. Thank you very much. – user3438958 Jan 15 '15 at 16:43
  • @Daniel - Is there a reason that you don't default your cPanel setup to that one that works well (better) with WordPress? (I do stand by my statement that Multisite on Shared hosting is a bad idea, and not recommended - You're running multiple sites. It'll make you be the bad neighbor if you get popular.) – Ipstenu Jan 15 '15 at 16:46
  • @user3438958 I am glad that the issue was resolved and now your site works just fine on our servers :) – Daniel Kanchev Jan 16 '15 at 7:35
  • 1
    @Ipstenu SiteGround hosts many different apps and not just WP. Some applications require the UseCanonicalName to not be changed. We have a procedure that we follow and we change the VHost settings if we install a wildcard SSL for a WP Network app. There are different types of shared hosting and depending on the size of the Multisite a certain plan may be suitable for the client's needs. In addition, we do notify users if their sites consume too much CPU/RAM. This way we prevent server overloads – Daniel Kanchev Jan 16 '15 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.