1

I have a subdomain multisite installation in site.com, with subsites such as sub1.site.com, sub2.site.com etc. I needed to transfer one of these sites to an own domain, sub1.com.

So I changed the domain value from sub1.site.com to sub1.com on the network admin panel and at first it seemed to be working. However, I was not able to log in to the admin panel on the transferred site at sub1.com/wp-login.php. No error messages, but returned on the same page every time.

I figured this was a cookie problem, and I changed the COOKIE_DOMAIN value to false in wp-config.php and it started working again.

However, later some users using other subdomain sites reported they have had problems logging in, but managed to do so eventually by trying many, many times.

I was wondering if this was a one time problem because of the changed cookie settings, or is this a real problem that I should worry about? Is it OK to leave the COOKIE_DOMAIN value to false? I did try installing the MU Domain Mapping plugin, but didn't manage to set it up right. Can this be done without it?

  • 1
    This works for me when I set the constant to an empty string. – fuxia Jan 14 '15 at 12:27
  • I tried that, and now I'm not able to log in at all to sub1.com site, even though I tried to change it back to false – Kari Jan 14 '15 at 13:50
  • Are all browser cookies deleted? – fuxia Jan 14 '15 at 13:51
  • Sorry, I was testing a wrong site. So, actually the empty string works equally well as false. I'll leave that on, wait and see if there are any problems. Thanks for the suggestion. – Kari Jan 14 '15 at 13:59
0

Simply add this line of code to wp-config.php near your Multisite config settings.

define('COOKIE_DOMAIN',FALSE);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.