2

Running Wordpress 4.1 on a CentOS 6.5 instance through VirtualBox as a dev server. When logged in as admin on both ssl and non-ssl sites Wordpress curl requests are taking a long time to run (45+ seconds overall before page loads). This renders my dev site unusable, as you can imagine.

While browsing around I found many people complaining of this extremely slow curl issue and I've discovered that setting the WP_INSTALLING constant to true speeds the site up 100%. I imagine it blocks all outgoing requests?

What are the consequences of setting this? I see that it breaks my front-end (admin side works well).

define('WP_INSTALLING', true);

Or, How can I just disable all outgoing requests? I profiled the page load and it appears that 65% of the hanging is due to curl requests. I just want to disable these external checks.

  • 3
    Did you try define('WP_HTTP_BLOCK_EXTERNAL', true); – Wyck Jan 13 '15 at 17:58
  • 1
    Please add your comment as an answer and I'll accept it. That was exactly what I needed. I didn't know that constant exists. Thanks! – adamgedney Jan 13 '15 at 18:50
  • Telling WordPress that it is installing an update seems an odd way to improve performance, for sure! – Matty J Mar 3 '16 at 22:09
0

I want to credit @wyck for his answer of setting:

define( 'WP_HTTP_BLOCK_EXTERNAL', true );

I also just wanted to add that this and a lot of nice other config options are nicely documented in the Codex.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.