0

I installed WordPress 4.1 on my server. All the files are installed, and I can login correctly without errors. But if I login through FTP I can't find the wp-content folder. If I do the above on my server panel through the file browser I can see the wp-content folder correctly.

For some reason it is hidden when browsing through the FTP client. I tried FileZilla but also other FTP clients. All of them do not show the wp-content folder.

I tried to change the folder permissions, but no effect.

Anyone knows how to fix this, or what the cause of it might be?

1 Answer 1

2

I kept on searching, and finally found something that fixed this issue. For those who are using CentOs 7 in combination with Plesk 12:

The issue is with SELinux.

When it’s used in Enforcing mode (which is the default), wp-content does not show itself via FTP. Switching it to Permissive mode or disabling SELinux altogether solves the problem.

The entire issue will be fixed in the next release of Plesk, and it’s already working in the latest update to the Plesk Preview 12.1.13. CentOS 5 and 6 are not affected.

To disable SELinux on CentOS 7 we can use this: setenforce 0

Or, to switch to permissive mode, use this: setenforce permissive

Now we’ll need to restart the xinetd service as well as Plesk for the changes to take effect:

systemctl restart xinetd.service
service psa stopall
service psa restart

If the server is restarted the above settings will be lost. To permanently use the above settings you should edit the selinux config file:

vi /etc/selinux/config

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=enforcing
# SELINUXTYPE= can take one of these two values:
#     targeted - Targeted processes are protected,
#     minimum - Modification of targeted policy. Only selected processes are protected. 
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.