0

I am migrating my WP website from staging to production and I have a problem with Dashboard access.

When I try to access

http://<domain>/wp-admin.php

it redirects me to

http://./wp-login.php?redirect_to=http%3A%2F%2F<domain>%2Fwp-admin%2F&reauth=1

I can login with going directly to http://<domain>/wp-login.php and I can go to any Dashboard page but cannot change anything (with Save button) without redirecting to http://./wp-admin/….

For example, if I want to change post content,

  1. I do it and hit Save button.
  2. Then I redirects to http://./wp-admin/post.php?post=20&action=edit&message=1.
  3. Then I go back and see that post changes are saved.

The same problem is with changing Permalinks settings.

So what is broken: there is a dot . instead of my domain in redirect URIs.

Maybe it is because of cyrillic одиссейдом.рф domain?

Have I add some rewrite rules to fix it?


UPD:

I saved a page, go back, save again and there is no problem.

Then I tried to change site title in Settings/General and there is no problem too.

Then I tried to turn off Emoticons in Settings/Writing and there is no problem.

But activating/deactivating a plugin goes with problem.

I have no idea, my friends.

1
+50

Possible solution: * go to permalinks under settings and check URL structure with your desired domain name. Even if the URL seems to be right, click the desired structure and save. This was handy while i migrated 2 websites. or * look for "wp_options" table in your database. You will find "siteurl" & "baseurl" row. Check if they are the right one.

Optional: search the whole database for the right URL.

  • I checked my DB twice before creating this question and twice again now and home and siteurl is ok but baseurl was just missing. So I just added baseurl with my domain and it's work! Thank you! – Даниил Пронин Jan 23 '15 at 8:18
  • one more time, it helped me just once. I still have this trouble. – Даниил Пронин Mar 25 '15 at 7:34
0

I advise you to:

  1. Go to /wp-admin/options-general.php and see if your site urls are correct. If it works change them or edit them in the database manually;
  2. Delete your .htaccess file or replace it with a default one;
  3. You can also add the following lines of code to the wp-config.php file:

    Define('WP_SITEURL','http://your-site-url.com');

    Define('WP_HOME','http://your-site-url.com');

0

Can you access :

http://example.com/wp-admin/options-permalink.php

If you can try to change the option and reselect the same one and save

  • Many times error like this are only related to the "permalinks" I had the same "issues" with Polylang (multilingual plugin) but it's because it's creating permalinks too and until you do no "resave" those information (even though you see your new URL) it's like the information is not properly saved. Ohhhh and of course if you have any plugins that creates special permalinks for your website, I suggest to go ahead and do the same thing, "re-save" those options to make sure they have the proper information) – pSyToR Jan 22 '15 at 14:09
0

I had same issue for me even admin as not loading, My db had correct site url and home.

The solution which worked for me is, adding following lines in wp-config:

define('WP_HOME', YOUR_SITE_URL);
define('WP_SITEURL', YOUR_SITE_URL);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.