When uploading a large file via the Media uploader, I get the infamous HTTP Error problem. I also have the following in the Chrome console:

POST http://www.nameofsite.co/wp-admin/async-upload.php 500 (Internal Server Error)

The file is actually uploaded and appears in the uploads directory. I have tried all suggestions in the question linked above.

Wordpress version is 4.0.1 on 1&1 UK shared hosting


With all plugins disabled, the error does not happen. If I enable, for example, revolution slider, the error occurs. However, I believe more than one plugin or a combination of plugins might be causing the problem. The fact that I am able to upload large images with all plugins disabled leads me to believe that a function or functions within certain plugins is interfering with async upload and that this is not a server config issue.

Other plugins causing the issue - uploadcare, fusion-core

  • check your php error log to see if there's anything helpful there Dec 12, 2014 at 17:51
  • @karpstrucking I've done that and see nothing relating to it, despite having enabled logging everywhere. I've also tried disabling plugins one by one etc.
    – codecowboy
    Dec 13, 2014 at 7:42
  • @RyanLoremIpsum thanks for the reply. Please see my update
    – codecowboy
    Dec 22, 2014 at 11:20
  • Keep testing with individual plugins enabled to narrow it down. Make sure you have the most recent version of Revolution Slider installed. There are a lot of posts on the web regarding 500 errors an Revolution Slider.
    – iyrin
    Dec 22, 2014 at 11:27
  • I had a similar problem, when I was uploading large image files the server ran out of memory. Having more active plugins means less available RAM. Increase the available RAM or decrease the image size. Alternatively, you could try to calculate how much RAM you would need for your uploads. Dec 27, 2014 at 23:22

2 Answers 2


It's a bit of a shot in the dark, but would you like to move up your memory limit? My guess is that your uploader fails on uploading big files with more serious plugins on just because they are using some of the memory too. In some cases "Memory exhausted" message does not appear if you don't have the right server settings.

In any case you should have a verbose error message somewhere in the web server logs, as 500 means exactly this: "There is an error on the server side and I'm not showing it to you, visitor!".

  • I came to this conclusion myself in the end. There is a hard memory limit on this shared hosting. Uploading a large image with a few plugins enabled was enough to exceed that limit it seems. Unfortunately 1&1 do not allow you to see more detail on the 500 error, even with PHP error logging enabled. The 'solution' was to move to a new host.
    – codecowboy
    Dec 28, 2014 at 6:58
  • If hosting don't allow you to edit php.ini for enabling debugging, you can add these in your wp-config.php and look for a log file in wp-content: define('WP_DEBUG_LOG', true); define('WP_DEBUG', true); define('WP_DEBUG_DISPLAY', false);
    – vlood
    Dec 28, 2014 at 15:14
  • thanks but 1&1 does allow php.ini in subfolders (put one in /wp-admin too) and I also enabled those options but still did not see more detail on the cause of the 500
    – codecowboy
    Dec 28, 2014 at 15:40
  • That's why I'm suggesting you get those constants in wp-config.php, because then you'll get all errors and notifications in a log file in wp-content folder. Otherwise not all messages will be outputed in the browser, even if everything is fine with the hosting and the php.ini settings. I'm writing all these just as a followup advice for when other case like this happens, I'm glad that you managed to cope with the problem anyways :)
    – vlood
    Dec 28, 2014 at 15:53
  • For me, this answer also helped: wordpress.stackexchange.com/a/17630/103228 It's also important to make sure the dimensions of the image fit into memory. In addition to the file size of the image.
    – intagli
    Mar 29, 2018 at 16:18

If you have upgraded the PHP version. This might cause the old plugin to do so. Same thing happened with me. I upgraded php 5.6 to PHP 7 and same error had occur. When i reinstall the PHP 5.6 it started to work normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.