I'm running WP 3.1.2 on an Apche server with the latest PHP installed. My WP is setup for a subdirectory multisite. The themes for the sites are usually a modified TwentyTen theme.

After installing a new plugin, I activate per site, not network, and I'm able to then click through to a few links in the admin UI before I'm prompted with an error starting with Warning: require_once

It doesn't matter what plugin is installed or how it's activated (per site or network). I have verified that the "missing file" is where it should be. I am using the latest version, most of them have been updated with in the past month or so and as per the official WP forum for the plugins, other users claim them to work properly.

It's becoming a real nuisance to have to go into every plugin and hard code the directory to each plugin file. I have tried reinstalling all the WP core files to no avail.

Has anyone else seen this or know how to fix it?

Edit: On a completely different domain with a brand new install of WP on a new database, I'm seeing hte same thing. Any new plugin install shows a missing file error. This is extremely annoying and I need to fix it. I suspect it's something within Apache but not sure.

  • you can see it here: nwtechanddesign.com
    – NW Tech
    Commented May 13, 2011 at 21:59
  • Where is the file Flow.php coming from? What is character encoding set at? Have you tried activating twentyten and seeing if you still get error? Sounds like either a character encoding issue or a problem with your theme.
    – Chris_O
    Commented May 13, 2011 at 22:39
  • on the server, the flow.php resides in '/nwtechanddesign.com/public_html/wp-content/plugins/web-invoice' Per my wp-config.php the encoding is 'define('DB_CHARSET', 'utf8');' When I activate this for a single site, it shows the error for all sites on the WP multisite network regardless of theme. By modified TwentyTen theme, the only modifications were done to the CSS not the Coding itself. I've also tried deactivating all plugins to see if any were causing the problems, but nothing works.
    – NW Tech
    Commented May 13, 2011 at 22:50
  • What is the error when the web invoice plugin is deactivated? I ask about character encoding because of the strange characters in the error message: (include_path='.:/usr/local/lib/php') in ø¢
    – Chris_O
    Commented May 13, 2011 at 23:02
  • certainly. The only way that I can gain access to the site is to delete the plugin via FTP (which I just did). I attempted to install a different plugin. This time the Wordpress SEO by Yoast. Again the files that are missing are in the proper directory '/nwtechanddesign.com/public_html/wp-content/plugins/wordpress-seo'. Surely not all of these plugins are written in correctly for file directories
    – NW Tech
    Commented May 13, 2011 at 23:50

2 Answers 2


The problem is defiantly not with the theme or any specific plugin. The problem is the fatal error thrown anytime an include or require is seen.

My only other suggestion is to open your php.ini file and find the line


and comment it out by placing a ; infront of it so it looks like this:


This will cause php to use the default include path which might fix the problem.

After you make the change restart apache $ /etc/init.d/apache2 restart or $ /etc/init.d/httpd restart or $ service httpd restart depending on what distro of linux your running.

  • Just tried this. Didn't seem to affect anything. So I deleted the problematic plugin (Wordpress SEO by Yoast) via FTP, then reinstalled it and ended up with the same error :(
    – NW Tech
    Commented May 14, 2011 at 1:19
  • It appears that after the error sits for a while, the site returns, only to fail after browsing to one or two pages.
    – NW Tech
    Commented May 14, 2011 at 1:39
  • Any other suggestions?
    – NW Tech
    Commented May 15, 2011 at 4:00

I ended up migrating to a new server and that fixed all the problems. I think something was corrupted on the original server after an update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.