1

I have a custom post type and the permalink shows up but I am unable to modify it like I can with Pages and Posts. Is there a way to enable this? I have a few conflicts with some pages and I'd like to fix them but I can't. Any ideas?

  • Do you have a tab in wp-admin for your cpt? – shanebp Dec 5 '14 at 20:26
  • Why do you have conflicts? This is unlikely unless you bent permalinks in some non-default direction, which very well might be the reason for issue with editing. – Rarst Dec 5 '14 at 21:01
  • Clients aren't always conscious of these things when created content. They created the CPT post first, but it's not meant to have a page. So when they created a page, they named it the same thing. Got the -2 after the slug. Don't want that if we can avoid it. – paper_robots Dec 5 '14 at 21:07
  • duplicate slugs shouldn't be an issue in different post types. are there posts in the trash with the same slug? – Milo Dec 5 '14 at 21:55
  • Nope wasn't anything in the trash. As soon as I changed it via the database thought I was able to change the Page. So something was linked. I found under Screen Options a box for Slug. It didn't quite work the same as on Pages but it gave a box for editing it. Did the trick. – paper_robots Dec 6 '14 at 6:08
3

Found a box under Screen Options to display the Slug on the custom post type. Created a metabox with the slug to be edited, not quite how it works on Pages but it solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.