Can anyone help me figure out both which plugin might be causing this error and how I fix it?

[4405235.617144] Out of memory: kill process 1450 (apache2) score 75568 or a child
[4405235.617155] Killed process 1450 (apache2) vsz:302272kB, anon-rss:4304kB, file-rss:284kB

That's the last one, but there are hundreds of errors like that before I rebooted...

I'm running WP 3.0.1 on Rackspace Cloud

I figure it has to be something that is either pushing or pulling an RSS feed, so here are the most-likely contenders

AddToAny FD Feedburner Feedlist FT Facepress II (which doesn't work anyway so I'll deactivate and save that for another question) Intense Debate Postalicious

If there's a way to figure it out without taking them all down one at a time, I'd appreciate the help. I pull in content from my delicious and posterous feeds and push it out to RSS, so I'd lose a lot of functionality taking them down.

Thanks in advance.

  • Does this issue show itself on site? Out of memory errors are usually end up with page interrupted at some point and "out of memory" error by PHP and file where it happened. If you are not experiencing such I am bit puzzled where can this be happening (maybe on wp-cron execution).
    – Rarst
    Sep 12, 2010 at 13:46
  • the site becomes inaccessible, both the front page and the admin pages. i also can't get on webmin, but it does respond to pings.
    – Law Shucks
    Sep 12, 2010 at 15:31
  • This is not my specialty, but I think this doesn't look like generic WP/PHP out of memory situation. More like some issue with Apache configuration. I'd start with hosting support.
    – Rarst
    Sep 12, 2010 at 16:32

2 Answers 2


"RSS" stands for "resident set size," one way to measure the amount of memory used by a process in Linux. It does not refer to RSS feeds. This probably has very little to do with WordPress, and everything to do with the amount of RAM in your box and how much memory Apache is using. I would recommend looking for answers on Server Fault, ie. Apache hanging with MaxClients is reached. You may be trying to spawn more Apache children than memory allows.


I've had the same problem, the problem is your server is getting overloaded. I would track down the source of the problem. To resolve this issue I had to increase my server size to 1024MB, optimize apache and setting up caching. W3 Total Cache is an excellent plugin for WP to help reduce server load and works with the RackSpace CDN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.