0

Page not found error when using permalink ‘postname’setting.Some pages are working for example http://example.com/questions is working but pages like http://example.com/questions/something. This is the case with my custom theme.Twenty twelve is working fine.Any suggesion?Default permalink setting also works fine.

3
  • 1
    Please provide more details about your custom theme. Are you trying to access a custom post type? Page? Post? Is "something" a child of "questions" or is it "questions" a custom post type, and "something" the post?
    – pwbred
    Commented Nov 26, 2014 at 15:55
  • In this link 'example.com/questions' questions is a custom post type named 'questions'.I am using DW question & answer plugin.The hyperlink Upto that first slash is working.The second link is a link to a particular question like example.com/question/how to prevent kidneystone & the word 'question' is actually a custom permalink provided by that plugin.
    – Anoop
    Commented Nov 27, 2014 at 8:57
  • If the custom post type is provided by the plugin you are using, your best bet to get support would be from the plugin's author here.
    – pwbred
    Commented Nov 27, 2014 at 18:47

1 Answer 1

0

This is likely related to a problem with the plugin itself, or a conflict with another plugin.

The other thing to check would be that your .htaccess file exists and is writable by WordPress. Permissions of 644 are what is recommended see this codex entry.

Ownership of the .htaccess file would generally need to be the apache user (sometimes this is www, on CPanel its usually nobody, but that will vary by web host or Operating System). If you're running on Windows, that is another story.

There is another decent article about .htaccess permissions here.

For posterity, here is how to change permissions and ownership of the htaccess file:

chmod 644 .htaccess
chown apacheuser:apacheuser .htaccess

You can usually find out permissions and ownership in your website's root by using this command:

ls -l

Remember to be careful when changing ownership and permissions and consult with your hosting company if you are at all unsure of what you're doing.

7
  • No i checked everything related to htaccess the problem is with my custom theme only.Something is missing in my theme.Other themes are working fine.How to add support for custom post display in custom theme
    – Anoop
    Commented Nov 28, 2014 at 10:54
  • Nothing is missing from your theme, your theme is doing something wrong if its preventing a custom post type from working.
    – Milo
    Commented Nov 28, 2014 at 13:47
  • i have used another plugin anspress that is having custom post type but it is working fine. i have nothing more to say.
    – Anoop
    Commented Nov 28, 2014 at 13:52
  • then you should ask the people who made the plugin that doesn't work, as was suggested yesterday.
    – Milo
    Commented Nov 28, 2014 at 14:03
  • some plugin authors gave vague ideas.So i asked here.Some people have faced similar problems in the past.They can help me.
    – Anoop
    Commented Nov 28, 2014 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.