I have had a site that has been working perfectly for the past few months. Then all of a sudden when I go to upload an image via the Media Manager on the Admin Dashboard I get a 500: Internal Server Error.

I don't understand what might be causing this. I checked my server error logs and there is nothing in their that relates to this error. I noticed that I can upload small files but just not large ones and by large I'm only talking between (3 - 5 Mb).

I've tried a few different things but they have not worked.

  • Deactivated my theme - no change
  • Deactivated my plugins - no change
  • made change to htaccess file - no change

I added this to my htaccess as I read it could be a security issue, but it did not work.

<IfModule mod_security.c>
<Files async-upload.php>
SecFilterEngine Off
SecFilterScanPOST Off
</Files>
</IfModule>

I also added this to my wp-config file:

DEFINE('WP_MEMORY', '64M') but that made no difference either.

Any help would be appreciated.

  • Does this happen on a vanilla WordPress install on the same server? I saw you said you disabled your theme and plugins, but some make changes and don't undo them on deactivation. – Andrew Bartel Nov 21 '14 at 18:46
  1. after change your memory limit , open your web page in some other browser or delete all your history and cache values in your browsr,,,,
  • That didn't work – Javacadabra Nov 21 '14 at 12:17
  • Change your Memory limit as : define('WP_MEMORY_LIMIT', '296M'); , and check after delete your past browser history,,, – Seenuvasan Velayutham Nov 21 '14 at 12:28
  • Unfortunately, that also did not work – Javacadabra Nov 21 '14 at 12:32
  • 2
    Please read this how to answer – kaiser Nov 21 '14 at 13:43

I think php version is issue , Add following code to .htaccess and then try to upload :

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.