5

I am really struggling with this one - hopefully someone here can help...

I am installing a brand new, fresh version of Wordpress v4.0 (A task I've performed easily 100+ times before without incident)

I have setup a brand new sub-domain and database for it then run the install script... But, everytime I try, I get caught in an infinite loop...

I tried deleting the sub-domain and database and recreating a new, completely different sub-domain and database name but the same thing occurs... I also delete the wp-config.php and start over again but always, when I get to point 4, it gets caught in an infinite loop...

The install process:

  1. got oo URL
  2. Select Country
  3. Click "Let's Go"
  4. Enter the db_name, db_user, password, host and table prefix and click submit
  5. Click "run the install"

But every time, I get the same result:

This web page has a redirect loop

The web page at http://www.domainname.com/wp-admin/install.php has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer. Learn more about this problem. Error code: ERR_TOO_MANY_REDIRECTS

I tried clearing the cookies but I know that's unrelated because I also went to rexswain.com and viewed the http header and it also gets caught in the same redirect loop...

I don't even know where to start looking!

There is no .htaccess file - 100% confirmed!

And when I check the database - no tables have even been created!

I am perplexed - any advice on how to do some debugging would be awesome!

  • Check your permissions and make sure they are correct (codex.wordpress.org/Changing_File_Permissions), I always have the rule, if you can't figure it out, its probably permissions. – Digitalchild Nov 20 '14 at 6:40
  • All files are 755 – php-b-grader Nov 23 '14 at 22:41
  • Are you trying install the website in a sub-folder? Can you share the website url and htaccess? – Nikhil Dec 9 '15 at 9:42
0

I finally found a solution to this problem and thought I would post my solution for anyone looking for assistance.

My main website sits on /public_html on my server I was installing new sites on a subdomain (e.g. newwebsite.com.au) in a sub-directory: /public_html/sites/newwebsite.com.au

Even though /public_html/sites/newwebsite.com.au was the root directory for the subdomain: newwebsite.com.au for some reason, the web server was still reading and using .htaccess from the parent/parent: /public_html

I had security software installed on the main website which was blocking install.php from executing.

0

Maybe; Edit the default ssl conf to point to /var/www/html/newwebsite to match newwebsite.conf.

You must place your "default-ssl.conf" file inside:

/etc/apache2/sites-available

And after, a2ensite command it will create a symlink for you inside:

/etc/apache2/sites-enabled

sudo a2ensite default-ssl.conf

Then SSH

service apache2 reload /or/ service apache2 restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.