0

I have a custom post type and a related taxonomy which is called "Asset_Type":

enter image description here

Which is perfect. However, if I create a post with the default Wp Post type, I still seem them as categories:

enter image description here

I'd like to not confuse posters and keep them separate. Only show the custom taxonomy for the custom post type.

In the menu system, these items are showing up in "categories" under "posts" AND under my custom taxonomy:

enter image description here

  • 1
    That's very strange. Default behaviour is the one you desire. There is something that are mixing up categories and custom taxonomies. Impossible to say what without seeing code. – gmazzap Nov 16 '14 at 16:35
  • Please provide the code where you registered your taxonomy. Make sure you're assigning your taxonomy to the correct post types in the $object_type parameter. codex.wordpress.org/Function_Reference/… If you're assigning to standard posts as well as a custom post type, you'd write an array of the post types in that parameter: array('post','custom_post_type'). You'd replace "custom_post_type" with the slug of your post type. If this doesn't help, please provide your code so we can help. – RachieVee Nov 17 '14 at 17:56
  • Looks like someone might have manually created them in both places. I have deleted the duplicates and will see if they return. – Steve Nov 21 '14 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.