I have template file named "page-manga" in my theme folder and my page's named manga too. In that template I have manga reader script running. Manga reader script has own variables. Wordpress permalinks settings now default mode and my URL like this;

mangayurdu.com/?page_id=471&manga=Kingdom&chapter=001&page=2

When I change permalink settings to postname it doesnt apply to "manga=Kingdom&chapter=001&page=2" part.

How can I fix this?

  • half of the solution depends on how the manga reader script generates those links, you may need to ask this of whomever created it. the other half is adding rewrite rules to handle incoming requests. – Milo Nov 15 '14 at 0:09

You would probably be better served to not rely on the page-pagename.php method of applying custom templates to a page, and be more deliberate with assigning the template.

At the top of your page-manga.php file, include a template reference:

<?php
/*
Template Name: Manga Page
*/
?>

Now on your Manga page, find the Page Attributes metabox and select "Manga Page" from the Templates dropdown. Save/update the page.

This way no matter what permalinks settings you choose, WordPress explicitly knows which template to use for that page.

You can find more information on WordPress templates here: https://developer.wordpress.org/themes/template-files-section/page-template-files/

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.