0

I have a weird issue: I changed my timezone, hit "Save," and was immediately logged out of the admin panel. Now every time I try to access the dashboard after logging in I'm immediately logged out.

My editor has not been effected by this—apparently it's only my account.

I've searched Google, the WordPress.org support forums, and WordPress.se to no avail. I've also tried clearing my browser cache and have tried accessing the panel in both Chrome and Safari. Still no go.


EDIT: Per @AndrewBartel's suggestion, I tried spinning up a clean install of WordPress and making the change, and everything worked fine, so it's something with my installation.

I've installed every extension on the broken site to the clean install one-by-one, checking to see if any one introduces the timezone issue. Nothing. Here's the list:

better-wp-security          Checked, but not configured the same...
[CUSTOM PLUGIN]             Checked, not the problem
disable-google-fonts        Checked, not the problem
profile-builder             Checked, not the problem
wp-security-audit-log       Checked, not the problem
disable-visual-editor       Checked, not the problem
shortcodes-ultimate         Checked, not the problem
wp-super-cache              Checked, not the problem
editorial-calendar          Checked, not the problem
updraftplus                 Checked, not the problem
wp-ultimate-csv-importer    Checked, not the problem
exclude-pages               Checked, not the problem
usernoise                   Checked, not the problem
wp-update-notification      Checked, not the problem
google-sitemap-generator    Checked, not the problem
wordpress-importer          Checked, not the problem
wpmandrill                  Checked, not the problem
hotfix                      Checked, not the problem
wordpress-php-info          Checked, not the problem

EDIT EDIT: Well, it started happening again. This time I didn't make any changes to the setting, so I think the timezone thing may have been a coincidence.

Bit more info: Trying to access the login page redirects me to the home page before I can even attempt a login. Logging in from my custom login form does log me in, and the admin panel displays. But then trying to navigate to the admin panel logs me out and redirects me back to the home page.

closed as off-topic by kaiser Nov 13 '14 at 18:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • Does this happen with a vanilla WordPress install? i.e. no plugins and one of the default themes? – Andrew Bartel Nov 7 '14 at 18:26
  • @AndrewBartel: I'm unsure; haven't tried that yet. Let me try spinning a new one up and test that out. – Nathan Arthur Nov 7 '14 at 20:10
  • @AndrewBartel: I tried with a clean install, and everything works fine there. I'm now installing my add-ons one-by-one to see which one breaks it. See OP edit for more details. – Nathan Arthur Nov 9 '14 at 18:35
1

This may be because of the way Wordpress handles logins with cookies. Have you tried deleting your cookies and sessins in your browser(s)?

Disclaimer: I know this belongs in a comment, but I don't got 15 rep yet, so I can't comment

  • In Chrome I cleared cookies and cache, as well as hosted app data and content licenses just for good measure (since I didn't know what those were). Is there anything more I should clear? – Nathan Arthur Nov 7 '14 at 19:13
  • Then it's not the browser. Did you change the timezone for the website, or the whole site? Only trying to rule out any problems with logging in with a timestamp "from the future" – Jimtrim Nov 7 '14 at 19:53
  • I'm sorry, what would be the distinction between the two? – Nathan Arthur Nov 7 '14 at 20:09
  • One is a user-setting, one is a site-setting. If you changed it with WP's default "General Settings", it is site wide. If you changed the timezone for your user through a plugin, it's a user setting stored in <prefix>user_meta, and could cause some problems – Jimtrim Nov 7 '14 at 20:21
  • Ahh, I see. I did it through general settings, so it would be site-wide. – Nathan Arthur Nov 9 '14 at 14:30
0

Well, after a couple of days it seems to have worked itself out on its own. Wish I know what the problem was and how it was resolved. I guess I'll just have to be content with my restored access.


EDIT: Well, it started happening again. This time I didn't make any changes to the setting, so I think the timezone thing may have been a coincidence.

  • Eeesshhh, that's no good. What level of control do you have over the server? Is it shared hosting? Something wonky that your host did would be my next guess if it isn't your server in your server room down the hall. – Andrew Bartel Nov 10 '14 at 4:00
  • @AndrewBartel: I'm using DreamHost shared hosting. Do you think there's a way I could tell if they were messing around from logs somewhere? Should I be worried about a security breach? – Nathan Arthur Nov 10 '14 at 16:57
  • 1
    Dreamhost is pretty good, they'd let you know if they changed anything. I gotta admit, I'm a little stumped on this one. I think you're fine security wise unless you notice something else. – Andrew Bartel Nov 10 '14 at 17:14
  • Started happening again. See edit to this answer... – Nathan Arthur Nov 13 '14 at 15:44
0

I've found the problem. It's a plugin called iThemes Security.

Here's what I did to figure it out:

  1. I renamed my plugins folder plugins_old—and the website started working.
  2. I created a new, empty plugins folder.
  3. I moved each plugin back into the plugins folder one-by-one, checking whether or not I had access to the admin panel after each move.
  4. When I got to iThemes Security—surprise—I again lost access to the admin panel.
  5. Moving iThemes Security back into plugins_old again fixed the issue, so I know it wasn't just a coincidence.

I've created a support thread; you can see it here.

Big thanks to Rarst & kaiser in the chat room for teaching me how to debug. You can see the transcript here.

Not the answer you're looking for? Browse other questions tagged or ask your own question.