1

I am attempting to create a multisite as a subdirectory and I have followed the network instructions to the 'T'. The multisite seems to be set up correctly, the .htaccess and wp-config.php files seem correct and I was able to do a network setup, however when I go to my multisite page it comes up with a 404 error - Not found. This also then prevents me from logging into the admin side for this site.

My main site still works fine and I able to login to the admin side there and with help from a plugin I can access and manipulate the database. All newly created tables are there, the multisite URL and options all seem correct.

I've verified the .htaccess file matches what's in Wordpress. I've verified the appropriate location of .htaccess (public_html root) and it is writeable. We don't believe this is a permalinks problem as so much of my research has suggested.

After extensive research I was unable to find a solution, any help is appreciated.

Here is my .htaccess file:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
</IfModule>

and the end of my config file:

/**
 * For developers: WordPress debugging mode.
 *
 * Change this to true to enable the display of notices during development.
 * It is strongly recommended that plugin and theme developers use WP_DEBUG
 * in their development environments.
 */
define('WP_DEBUG', false);

/* Multisite */
define( 'WP_ALLOW_MULTISITE', true );

define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'www.mybusinessconnect.com.au');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');
2

I had the axact same problem.

My solution: edited/etc/apache2/sites-enabled/000-default.conf. It needs to look like:

<VirtualHost *:80>

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

        <Directory />
                Options FollowSymLinks
                AllowOverride all
        </Directory>
        <Directory /var/www/>
                Options FollowSymLinks
                AllowOverride all
                Order allow,deny
                allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

It works!

1

I faced same problem - wordpress multisite directory - 404 error for new site dashboard and site page, admin site and dashboard works.

My problem was in apache configuration - /etc/apache2/httpd.conf. Need to do 'AllowOverride All' under Section <Directory "/Users/user1/Sites">

And don't forget to enable mod_rewrite in httpd.conf:

LoadModule rewrite_module libexec/apache2/mod_rewrite.so

Otherwise it gives 500 error.

I don't know what these config represent, but this solved my problem. Hope this helps.

0

I had the same problems with WordPress multisites in both local development server and remote location.

Creating another network was no problem. When I clicked 'dashboard' or 'visit', the browser returns 404 error (not found). I have deleted/reinstalled new site many times ... the error remains.

I have checked the database. The wpx_ (x denotes the id) were added.

According info that I searched, no subdirectories will be added by WP. They are virtual as confirmed in database.

I have done the following:

  1. Edited wp-config.php to include: define( 'WP_ALLOW_MULTISITE', true ); to activate multisite.
  2. Clicked Tool -> Network Setup to install a new site
  3. Copied the info on wp-config.php and .htaccess to the respective files.
  4. Added new site as a subdirectory
  5. Viewed all sites
  6. Clicked either "dashboard' or 'visit'. 7 Error 404 displayed.

I have searched, explored the internet and tried the solutions. None worked. I think the problem lies in rewrite rule. But, database tables were created. This is what baffles me.

At the rate I am giving up on multisite.

Attached are screenshots for easier troubleshooting: wp-config.php.png and .htaccess.png

Any help is appreciated greatly.

M A Sani

0

According to the codex, these htaccess rules are for multisite https://codex.wordpress.org/htaccess

Subfolder Example

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

SubDomain Example

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]

That's what I used without problems on a hosted site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.