0

I have a multisite WordPress installation. When I am logged in as a super admin from the main website, and go to the dashboard from the main site into another site, it asks me for login details. When I enter the details, it gives me an error:

ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

I also added code in wp-config.php:

define('ADMIN_COOKIE_PATH', '/');
define('COOKIE_DOMAIN', '');
define('COOKIEPATH', '');
define('SITECOOKIEPATH', '');

Still the problem occurs, even though cookies are already enabled.

2

Cookies are enabled per default. By setting

define('ADMIN_COOKIE_PATH', '/');
define('COOKIE_DOMAIN', '');
define('COOKIEPATH', '');
define('SITECOOKIEPATH', '');

you just disabled them by setting the path to an empty string. The ADMIN_COOKIE_PATH per default is the SITECOOKIEPATH followed by wp-admin and the SITECOOKIEPATH is extracted from get_current_site()->path. See source. Just revert what you did and delete the constants from your wp-config.php.

Your actual problem seems that your browser has cookies disabled. Better fix that :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.