1

I'm getting "Download failed. Failed to write request to temporary file." when I try to download plugins, and the plugins (that were working) are now unable to write what they need to (namely a caching plugin.).

I'm running a CentOS on a VPS with Apache, etc and have suPHP installed. Permissions are set properly (644 and 755) and ownership of the files is under the user.

The issue has started since I added another user to my box (using centos webpanel FWIW).

Also, just verified that the other use CAN install plugins on its wordpress installation.

How did adding a user knockout my existing user?

So far none of the threads on this have solved my problem.


Edit: Also tried setting temp dir to wp-content and 777'd wp-content. Still no luck. Even with Apache restarts. I'm grasping at straws.

Could this be an issue with vhosts or suphp config?

  • Are both users in the same user group? – Courtney Ivey Oct 28 '14 at 19:39
  • They are not. Just to clarify: These are akin to having two different hosting accounts on a shared host, should they be in the same group? (also, it's worth noting that centos webpanel sets them up in their own groups.) – Tim Oct 28 '14 at 20:23
  • You should check the owners of the wp-content directories. Sometimes setting "apache" as owner solves the new plugin issue. – Courtney Ivey Oct 28 '14 at 20:25
  • It does make a change, but just beings me to the page to input FTP credentials, which isn't much better for me, unfortunately. There's some root issue with the user accounts working against each other, but I'm not quite sure how to get to the bottom of that one. – Tim Oct 28 '14 at 20:33
0

Make sure your disk space quota has not been reached. I had the same issue, and had to remove some old files to stay within the limit or just raise the disk space quota for the account.

I left all the original file and folder permissions the same as that didn't feel like a logical explanation as to why I couldn't update. Everything worked perfectly after I made some space on the account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.