0

I used BackupBuddy to make a copy of a website I'm working on and then used MAMP (Windows) to recreate the site on my localhost so I could work on it. I must have done something wonky because now the live site loads only the HTML (no CSS) and all of the links are "localhost/..."

I had access to the admin side of the site but never directly interacted with any files on the host server.

I've done a good bit of research on the issue but haven't found anything that matches this scenario.

Any ideas on what happened and how I might fix it would be greatly appreciated. Thanks.

12
  • Hi @Kevin, can you check the contents of your "Hosts" file. If you have trouble finding or opening this file please referrer to this page to help. If there is no reference of your server there warn me and I will post an answer here.
    – Bordoni
    Oct 26, 2014 at 2:27
  • Hi Bordoni ... The only references to localhost in my hosts file are: # localhost name resolution is handled within DNS itself. # 127.0.0.1 localhost # ::1 localhost
    – Kevin H.
    Oct 26, 2014 at 2:57
  • Before asking here did you contact the iThemes support? I mean they should have a quick answer for you.
    – Bordoni
    Oct 26, 2014 at 3:57
  • I didn't - I assumed it was a problem with something else, like maybe a database issue. It didn't seem likely that just installing a cloned version of the site on a localhost could affect the live site. I'll contact iThemes to see if they have any insight ... thanks.
    – Kevin H.
    Oct 26, 2014 at 4:04
  • Where exactly did BackupBuddy create the backup before you accessed it on your local machine? Did you overwrite the site with its own backup?
    – user4849
    Oct 26, 2014 at 4:06

1 Answer 1

0

Could be that the database for the local version is still connected to the live version. Check you wp-config file as not all host use local host for databases some use fixed addresses..

1
  • I'm still not sure how it worked, but it's fixed (though some image links are broken but I'm guessing they'll update soon). Here's what I did: - Started MAMP and went to "http://'live site URL'/wp-login.php" which took me to the WordPress dashboard, though with a localhost URL - Went to Settings > General and changed the WordPress and Site Address URLs from "localhost" to the live site URL I guess my confusion was in assuming that anything I did on localhost would not affect the live site. Thanks for the help, everyone.
    – Kevin H.
    Oct 27, 2014 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.