I have a simple Theme like below

enter image description here

Right now when I navigate to localhost and site root directory I am able to see content from header.php , footer.php and page.php.

then, I simply generated some pages for Navigation bar and to get a better URL I updated the permalink from default to Post Name format

enter image description here

Now while I have the the clean Ur as: Permalink: http://localhost/RumiPress/eyeglasses/

enter image description here

When I click to view the page I am getting enter image description here

I Google this and find some hints about the (.htaccess) so I just copied same format as Cedex enter image description here

but still getting same result. Can you please let me know why this is happening?


1 Answer 1


In order to work permalinks properly, you have to enable 'mod_rewrite' module in your apache server. Other wise it could not run .htaccess file and that is why it shows 'Not found'. It will be working if the permalink is disabled or set to default, right?

  • Hi Hakkim, thanks for reply but can you please let me know how I can enable it on WAMP? and how about Server side I mean I am using Awardspace.com free hosting , in this how can I do this?
    – Suffii
    Oct 23, 2014 at 5:51
  • I think, the Awardspace.com support team could help you on this. That will take only few minuets to do. Try to get their support.
    – Hakkim
    Oct 23, 2014 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.