0

I have a setup on wordpress with site1 and site2 under site1. I'm having problem on favicon on site2 because site2 favicon uses the favicon for site1.

i have a code on my header.php inside site2

<link rel="shortcut icon" href="<?php echo get_stylesheet_directory_uri(); ?>/favicon.ico" />

and i also put my favicon.ico file on the root and inside the theme im using but no success.

2
  • marking as possible off-topic as what browsers are doing with the info you send them is unrelated to wordpress. Commented Oct 26, 2014 at 6:19
  • im using wordpress for my cms. with 2 site conflicting my favicon.
    – MIke
    Commented Oct 27, 2014 at 1:00

1 Answer 1

0

For me its showing different on Safari and different on chrome. When I checked page source, I noticed favicon is being called thrice. Please delete other two instances and then check clearing browser cache for all browsers. I believe it should work then.

4
  • It must be cache. Please rename your favicon file to something else. Say hotelfs.ico and use this tag instead of earlier. <link rel="shortcut icon" href="<?php echo get_template_directory_uri(); ?>/hotelfs.ico" type="image/x-icon" /> It should work. Commented Oct 22, 2014 at 8:44
  • still the same on my chrome but its good on my other browser. I have clear my cache still the same.
    – MIke
    Commented Oct 22, 2014 at 8:52
  • @MichaelPon - Thats a mystery!! I just exported ico image to png and used that. Its working. I tested on chrome, FF, Safari. Am on Mac so can't test on IE. So please use png for favicon and that should do. Thanks. <link rel="shortcut icon" type="image/x-icon" href="<?php echo get_template_directory_uri(); ?>/hotelfs.png" /> Commented Oct 22, 2014 at 9:38
  • Yes, after using png do clear browser cache. Commented Oct 22, 2014 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.