I'm a bit stuck here. My Mac (running Mavericks) died on me last week, and I spent the weekend getting a new computer and restoring the backup of my old (thank God for backups people. If you haven't made one, go do it.) The new computer runs Yosemite.

I had a pretty great system set up on my old computer that I was REALLY happy with for running local installs of WordPress via a single installation without using WPMU. I have Apache, phpMyAdmin, and MySQL set up here on the new dev environment (I used to use MAMP, and then moved to ServerPress, but I ditched both for this new system - I like it a lot better), but the idiot in me didn't document how I did things.

My issue is interesting (I searched here, and couldn't find the answer) - and I think it's because of how I have the system set up to run these multiple installs without WPMU, but still running from a single installation of WP. I'm using aliases for this - basically I'm aliasing the base WordPress installation to my other directories, leaving the wp-content folder out. (each "site" has it's own wp-content folder- all other WP files are aliased in) I've got some wp-config.php magic going on to keep things tidy.

I don't know if it's because Yosemite is running a different version of Apache than Mavericks was, if it's actually the alias thing that's causing an issue, or my own ignorance of permissions/ownership that's the problem here (I'm assuming the latter), but I'm having an issue with uploading images and WP creating/updating an .htaccess file for me. Funnily enough, I'm having absolutely no issues at all updating/installing new themes and plugins, and/or WordPress itself.

I've manually created the .htaccess file and the /uploads directory (and yes, my permissions are indeed set to 755/644 for directories and files), and when I upload an image via the media uploader, it acts like it's uploading just fine. However, no date-based subfolder is created, and no image is actually put in the uploads directory. (It adds it to the database just fine though - no error messages or anything.)

I have Googled my brain out, and tried everything I come across. I can find no answer for this issue. I have tried all kinds of methods of changing ownership/permissions and nothing works. So I now turn to your smarter-than-mine brains. Would anyone have any ideas for me? (BTW, the "wheel" and "www-data" attempts always return me to "Illegal username/groupname" and won't take.) I'm positive this is an ownership issue, but for the life of me, I can't solve who should be owning what.

If it helps, I have tried solutions from these places: https://stackoverflow.com/questions/3740152/how-to-set-chmod-for-a-folder-and-all-of-its-subfolders-and-files-in-linux-ubunt

http://coolestguidesontheplanet.com/get-apache-mysql-php-phpmyadmin-working-osx-10-9-mavericks/

http://paulmason.name/item/change-apache-user-group-in-lion-os-x

http://francoisdeschenes.com/2013/02/26/enable-write-permissions-for-apache-built-into-mac-os-x

..as well as several other things I found through google that were similar solutions to the above. If it helps, my apache error logs have a lot of these in it:

[Mon Oct 20 08:04:02.516302 2014] [mpm_prefork:notice] [pid 74560] AH00169: caught SIGTERM, shutting down [Mon Oct 20 08:04:02.708508 2014] [core:notice] [pid 74619] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

and in my apache access logs: 127.0.0.1 - - [20/Oct/2014:08:04:17 -0400] "GET //www/sites/site1/wwwroot/wp-content/uploads/2014/10/image.jpg HTTP/1.1" 404 279 127.0.0.1 - - [20/Oct/2014:08:04:17 -0400] "GET //www/sites/site1/wwwroot/wp-content/uploads/2014/10/image.jpg HTTP/1.1" 404 282

I have absolutely no idea what that means, though - but they coincide with my attempts to upload images through the back end of WordPress. (PHP error logs show nothing.)

Any help/insight would be greatly appreciated.

  • Your server is crashing-- that is the "caught SIGTERM, shutting down" part of the first error. This is going to be too localized for this site. It will take hands on debugging/tweaking to sort out. – s_ha_dum Oct 20 '14 at 15:28
  • Thank you for that! I did sort it out on my own - but this is good to know. I'll have to look into it. (hopefully the fix I discovered takes care of this issue) – Shelly Oct 20 '14 at 16:51

I fixed it. It actually wasn't anything with the server permissions. It was PICNIC - the magical "wp-config" tweaks I put in - I put in an incorrect path to the uploads folder. Fix, tweak, done.

  • Please flag your answer as the answer. I just unnecessarily took the time to read your whole post only to see it's allready answered... but nice you found the error – Luckyfella Sep 18 '17 at 20:09

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.