0

I deleted an image from the Media tab and when I tried to upload another, I started getting this error:

The uploaded file could not be moved to wp-content/uploads/2014/10

I tried CHMODing the wp-content and uploads folder to 777; however, I still get the same error.

Note: I used the Duplicator plugin to move the site from one server to another. I'm not sure if this has something to do with my problem but I'm mentioning it just in case. The media uploads worked fine before transferring everything over.

  • Make sure all the image files exists in wp-content/uploads/2014/10 if not then upload them manually. – Robert hue Oct 17 '14 at 5:09
  • you should check the permissions of the 2014 and 10 folders as well – Mark Kaplun Oct 17 '14 at 5:48
  • @Robert There are so far no images in that folder. I'm trying to upload the first one. – Desi Oct 17 '14 at 5:56
  • @Mark Does this mean that I have to always keep the wp-content, uploads, 2014, and 10 folders to 777? Isn't that unsafe? Not sure why I was able to upload fine with 755 before the transfer. – Desi Oct 17 '14 at 6:04
  • @Desi, uploads and whatever is below it should be 777, wp-content should be more restricted permissions. – Mark Kaplun Oct 17 '14 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.