I have a WordPress installation on AWS and I was facing an issue that authors are not able to submit content like media in one go and a time-out error occurs. After refreshing the page 5-6 times authors are able to upload content again.

To mitigate this issue, I deactivated all the plugins and upgraded to WordPress 4.0 from the back-end, which also raised a problem and I had to rerun the update manually.

So I downloaded the latest WordPress Zip and followed the instructions as mention on http://codex.wordpress.org/Updating_WordPress.

Finally, in the last step, when I refreshed the browser window, it asked that the database needs an upgrade too. So I followed the on-screen instructions and logged into my WordPress.

After logging in, the WordPress back-end looks like in the following screenshot:

screenshot of WordPress back-end with not CSS being loaded

It looks as if no CSS being loaded. How can I solve this issue?

  • 1
    I think you might need to upload all files again in wp-admin and wp-includes. Possibly some missing file issue.
    – Robert hue
    Oct 8, 2014 at 13:15
  • See in the source of the site. I think your domain for the wp installation is wrong. Maybe you have change the domain, path for the installation inside the database or via constant inside the wp-config.php?
    – bueltge
    Oct 9, 2014 at 5:39
  • @bueltge I have not changed any thing in the domain or Installation directory or in the database. I have uploaded my previous wp-config.php file from the backup. still nothing. could you please elaborate more on the solution that you are trying to say
    – Neal
    Oct 9, 2014 at 14:06
  • @Roberthue I have uploaded all of the files 3 times following the guide lines in the link mentioned above. still the same thing is happening.
    – Neal
    Oct 9, 2014 at 14:07
  • Do you have check the path inside the source of the site? Is the path to the admin stylesheet correctly?
    – bueltge
    Oct 9, 2014 at 15:10

9 Answers 9


Adding these two lines to "wp-config.php" worked for me. I had the same issue.

define( 'CONCATENATE_SCRIPTS', false ); 
define( 'SCRIPT_DEBUG', true );

Also, remember to clear cache on server and browser.

  • 6
    Just define( 'CONCATENATE_SCRIPTS', false );
    – Valdrinium
    Mar 18, 2019 at 10:03
  • 9
    But why these two lines? What do they do? Why might these lines solve the issue? Could you update your answer for clarification?
    – leymannx
    Mar 25, 2019 at 9:59
  • 2
    It's 2023 and I fixed WP Admin using define( 'CONCATENATE_SCRIPTS', false );.
    – Space
    Jul 10, 2023 at 17:35
  • Why does this work? It also worked for me.
    – avia
    Sep 18, 2023 at 20:47

In wp-config.php before require_once add below code into file :

define('CONCATENATE_SCRIPTS', false); 
  • 1
    Please edit your answer, and add an explanation: why could that solve the problem?
    – fuxia
    Mar 25, 2019 at 11:49

First of all visit: how to fix wordpress admin style problem

it is possible that one plugin incorrectly enqueued some style or jquery file

in the wp-admin/load-styles.php file, change "error_reporting(0);" to "error_reporting( E_ALL | E_STRICT );" then refresh the page, if the page style return to normal, reverse the code change to it's initial state, and your site should look fine.

also adding these line to wp-config.php

define( ‘CONCATENATE_SCRIPTS’, false );
define( ‘SCRIPT_DEBUG’, true );

could help

Then if you have time:

  • backup your db (using phpmyadmin export)
  • install a fresh wordpress from scrach,
  • copy old theme folder to new wordpress (wp-content/themes/)
  • go to admin->plugin page
  • drop db of new wordpress,
  • import old db from your backup_db file, using phpmyadmin
  • refresh your plugin page
  • copy plugins to your wp-content/plugins/ folder
  • active them one by one to find out if one of them caused the problem
  • What is define( 'CONCATENATE_SCRIPTS', false ); for? And why might is solve the issue? Could you update your answer for clarification?
    – leymannx
    Mar 25, 2019 at 9:59
  • 2
    @leymannx Hi, CONCATENATE_SCRIPTS is the constant that make it possible for wordpress to concatenate all of the dependencies into one URL and load it together, and it only affect backend (Admin Panel), it is somehow works like what Cache plugins do on the frontend. combining the scripts together. Mar 25, 2019 at 15:27

I had the same problem and tried the above suggestions first, but they didn't work. Then I realized my issue was coming from mixed content being delivered and I found this answer, which references this answer and explains that it's how Cloudflare's headers confuse WordPress.

Adding the following to wp-config.php worked for me:

if ($_SERVER['HTTP_X_FORWARDED_PROTO'] == 'https') $_SERVER['HTTPS']='on';

but before the line:

require_once(ABSPATH . 'wp-settings.php');
  • This worked for me although I'm not using Cloudflare. My setup is using a jail in FreeBSD for the reverse proxy and another jail for the web server. Before trying this solution, changed the reverse proxy application, as well and changing three times the web server, from hiawatha, to apache, to nginx to caddy and styles continued not to load. Thanks!
    – Luis
    Aug 31, 2020 at 11:07
  • This was life saver answer for me. Many thanks. It did fix my issue Apr 18, 2023 at 18:36

I found that my wordpress was set to http:// but I had installed a certificate and needed https://

Changing the default to https:// in wordpress settings fixed it.


I had the same issue. I went into my ftp / file manager and discovered that my css folder in the wp-admin folder was missing (I have no idea how it happened). Which makes complete sense - the formatting is what is messed up on the admin site, but not on my actual website. I added the css folder back into the wp-admin folder and everything was solved.


I was using MAMP which runs on port 8888, and I had to change my Wordpress database's options table rows site_url and home values from http://localhost/ to http://localhost:8888/ and that fixed it for me.


For me it was an .htaccess file in wp-admin directory


This happened to me more than once, such as after migrating to a new domain.

First time: set domain in wp-config.php...

define( 'WP_SITEURL', 'https://some.domain' );

define( 'WP_HOME', 'https://some.domain' );

Second time: set domain in SQL database...

wp_options > wp_options

wp_options > home

Note http vs https can also cause a problem if it is set wrong.

Not the answer you're looking for? Browse other questions tagged or ask your own question.