0

hope you are all doing good!

I have this problem. I had set "Post Name" as the URL scheme, therefore, I get www.site.com/article-title for blog entries. I've written a few test posts and I realize I want permalinks to look like this:

For blog posts: www.site.com/blog/article-title. For categories: www.site.come/blog/category/category-name. For tags: www.site.com/blog/tag/tag-name

So I made the following changes in the permalink settings page:

Custom Permalink Settings

And now I get the error 404 when I access a post or a page. What can I do in order to fix the problem? Thanks in advance! :D

PD. Sorry if my English sounds odd, Spanish is my native language.

3
  • Do the new posts you add work? Have you tried saving the permalinks again? You can go to settings > permalinks and hit save. This might fix it
    – Fraggy
    Oct 7, 2014 at 20:50
  • @Fraggy Yeah, I had tried that. It was a .htaccess file issue . This link helped me to fix the problem: codex.wordpress.org/…
    – user60184
    Oct 8, 2014 at 15:42
  • I solved this issue by this way Apr 25, 2020 at 16:12

1 Answer 1

1

If your .htaccess file were writable, wordpress do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file.

1- Open .htaccess file and copy following data in that file.

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

2.After update file permalink issue will resolve.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.