0

So i followed a tutorial to install wordpress offline in xampp. It's up and running but login doesn't seem to be a full admin. It says i don't have sufficient privileges when trying to install a plugin. And when trying to make a new page it only offers 'submit for review'

I used phpmyadmin to insert a another user with user level 10 and wp_capabilities a:1{s:13:"administrator";s:1:"1";} but it still says i don't have the privileges. Any help?

EDIT I just started over from scratch. I don't know how to mark a question as closed. Thanks for all the help

  • 1
    Do you have any plugins installed that may be affecting this? Is this happening to all "administrators" (for example, if you create a new admin user) or just you? – Howdy_McGee Sep 25 '14 at 19:36
  • @Howdy_McGee all admin users and no there are no plugins installed. I've tried creating a completely new database and it still happens – Adrian Le Roy Devezin Sep 25 '14 at 23:23
  • Did you see that you are an Administrator under Users > All users? – Bernie Sep 26 '14 at 0:05
0

This post suggests that it may be an issue with the database itself, and you should run the 'repair database' feature via phpMyAdmin.

  • repair DB may fix the DB internal consistency but it is unlikely to affect the data in the DB, if the data is corrupt you can repair it only but using a backup. – Mark Kaplun Sep 26 '14 at 4:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.