1

I have WordPress installed on my localhost. All worked perfectly till today. But today when I enter http://localhost/wp-admin in the url to access the admin panel, it redirects back to the home page. I can't get access the admin panel. It's not happened before, whenever I try to access admin panel, it does. Please guys help me out....

Thank You.

  • Did you inspect the HTTP request(s) going on? – Geert May 3 '11 at 16:43
  • Maybe it is trying to redirect you to the login page, but that setting is incorrect. What happens when you go to http://localhost/wp-login.php directly? – Jan Fabry May 4 '11 at 13:17
2

How I resolved it:

Log in to your PhPmyAdmin in your CPanel and look for the database for your wordpress.

2 steps once there:
1. Change url by editing an entry in a table(wp-options) of the database to rectify the problem.
2. Next, login to wp-admin and go to settings and change the url.

1

This sounds more like a "Troubleshooting" support question: http://wordpress.org/support/forum/how-to-and-troubleshooting

1

May sound like a dumb answer - but did you double check to make sure that Xammp or whatever program you are using to run the localhost server has been turned on?

1

Well if you install wordpress in www then your localhost index page will be override and if you ignored that then your wordpress index page was not there it redirects you to home page so your wordpress index page is not there. or if you save it in any folder then check your url.

1

I had this problem. I forgot "www" in front of my domain name when I deployed.

I used WebMatrix's SQL editor to find the siteurl option - changed it to http://www.mysite.com.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.