4

I recently updated to wordpress 4.0. However, when I try to preview my drafts, I receive an error saying that I do not have the permission to do so. I've cleared my cache and cookies and restarted my computer but with no success. Also, I've checked my Site and Wordpress URLs and they were the same as before I updated my site:

http://example.com/wordpress

http://example.com/leicester
  • Does this happen only when you try to preview drafts? Have you tried to do other tasks successfully? – Christine Cooper Sep 18 '14 at 21:43
  • Hello, that;s the only time that it happens. I can pretty much do most other things but whenever I try to preview the draft, I recieve that error. The only other things that does not work are shortcodes for certain plugins but this was already an issue – Tommy Rufai Sep 19 '14 at 18:54
  • Have you tried logging in as another user to see if the issue persists? – deadlyhifi Oct 12 '14 at 8:24
1

Do you have any kind of cache plugin used? Perhaps to help speed up the website. If Yes that just may be the issue here.

Another suggestion is change the current active theme to any default WP theme (twentyThirteen, TwentyFourteen), and then see if Preview give you an issue.

If it does not, then its possible that there is an issue with your current theme.

If the Preview issue persists, de-active all your plugins and check Preview with the default theme.

Preview should work fine now.

Next, one by one, activate each plugin and check preview until you discover which plugin is causing this problem.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.