0

I'm trying to log-in to the admin page of my website without any luck, only i got white page, hers what i did to identify the problem:

  • I have enabled the Debugging in wp-config.php

    // Enable WP_DEBUG mode
       define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
       define('WP_DEBUG_LOG', true);
    
    // Display errors and warnings 
       define('WP_DEBUG_DISPLAY', true);
       @ini_set('display_errors',0);
    

And tried to log-in but still getting white page, any idea of what i messing her?

  • What is in /wp-content/debug.log? Any error messages? – realloc Sep 18 '14 at 10:16
  • You are most probably getting the white screen of death which is caused by some fatal or parse error. This just doesn"t happen on its own. What changes did you make, can you remember, and do you have ftp access – Pieter Goosen Sep 18 '14 at 10:25
  • I did't make any change, and i have FTP access that's how i enabled the debug mode, but no error is showing. @PieterGoosen – Ahmed Na. Sep 18 '14 at 10:52
  • Have you contacted your host to find out if they made changes on their side, maybe upgraded PHP versions? – Pieter Goosen Sep 19 '14 at 5:49
0

After a lot of search for how to solve this problem, her what I found to help in such a situation:

  • Enabling the Debug mode & display errors and warnings

    // Enable WP_DEBUG mode
       define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
       define('WP_DEBUG_LOG', true);
    
    // Display errors and warnings 
       define('WP_DEBUG_DISPLAY', true);
    

    at this point i hope some error message appears so can help identify the problem.

  • Some time no indication of what is the cause of the problem (like my case), so I changed the plugins folder name to anything (e.g. plugins.test) then try to log-in to the admin section again.

  • Now the admin section is working, so the problem was in one of the plugins.

  • To identify the plugin causing the problem, rename the plugins folder again to its original name but change plugins that you have inside the folder.

  • One at a time rename each plugin folder and test to login to the admin section.

For me, it was because of the gravity form plugin which causes the problem. I updated the plugin then admin section works. Hope this will help anyone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.