0

I have a wordpress website hosted on Lightspeed server. There's an error message displaying in admin login page and I can't access wordpress backend. This is the error

Warning: Cannot modify header information - headers already sent by (output started at /tmp/session_f54bfef1a94d74c2534c8668c57bb987:33) in /home/website/public_html/wp-includes/pluggable.php on line 1173

What I see is that there's some kind of problem with a cached/minified file (?) located in tmp/ directory, and I don't have access on that directory. I cannot access this file and get more information about this issue.

What should I do to fix this? Any suggestions please?

Note. The pluggable.php file is ok, I checked it for white spaces and also replaced it with the original file I downloaded from wordpress.org, just to be sure that it's not corrupted.

4
  • 1
    Is this the only error message? From quick search around it comes up in context of PHP unable to start session, but then there should be more errors about that.
    – Rarst
    Sep 14, 2014 at 12:42
  • Yes this is the only error displaying
    – ktsixit
    Sep 14, 2014 at 12:50
  • 1
    can you show us the content of your wp-config.php (remove sensitive info (db password, real url...) first!
    – pixeline
    Sep 14, 2014 at 13:39
  • 1
    - Try reviewing this codex to solve header already sent problem: codex.wordpress.org/…
    – Tara
    Sep 14, 2014 at 22:17

1 Answer 1

1

It means Wordpress is outputting something to the browser too early. The file indicated seems to be your own session file (php stores user sessions in small text files in the tmp directory).

Check first the wp-config.php file. Remove the final closing php tag. Make sure you're not outputting anything in that file (look for print_r, var_dump, echo, print, some html...). See the manual for more ideas.

3
  • In order to fix this I had to replace all wp-admin and wp-include files, with a fresh downloaded copy from wordpress. That fixed it. Thank you
    – ktsixit
    Sep 16, 2014 at 7:57
  • 1
    that's weird. Are you sure your files did not get modified by a hacker? You might want to change all your webhosting account passwords: ftp, sql, and wordpress's admin account. Better safe than sorry. Anyway, glad you got it solved!
    – pixeline
    Sep 16, 2014 at 8:12
  • Yes, I got suspicious about that too. There have been a lot of problems in my website the past days and I don't think that upgrading to 4.0 is only reason for that. Thank you for your suggestions:)
    – ktsixit
    Sep 16, 2014 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.