0

I'm doing some work on a live WordPress site, and before making changes wanted to create a local copy of the site to use. I've gone ahead and done that, (using BackUpBuddy) but I am getting this error for every page (except the home page)

Not Found The requested URL /index.php was not found on this server.

I've tried going to dashboard -> settings -> permalinks and re-saving and it doesn't work. If I change the permalink setting to "default" instead of "post name" I am able to load all the other pages.

I've done some investigating and tried changing a couple things in my .htaccess file in my text editor, but still no luck. Here's the content of .htaccess

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L] 
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L] 
</IfModule>
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /014-TGGGLocal/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /014-TGGGLocal/index.php [L]
</IfModule>

# END WordPress

I should also mention that .htacess and index.php are both in the directory indicated by the Site address (URL) setting on my General Options page. AND using post name "permalinks" works fine on the live version of the site.

  • is mod_rewrite enabled at all? – Mark Kaplun Sep 8 '14 at 3:57
  • 1
    Try removing the first IfModule block. – TheDeadMedic Sep 8 '14 at 13:12
  • @TheDeadMedic - that worked! Any idea what that is/why it was included in the first place? – user59372 Sep 8 '14 at 15:00
  • Probably because it was already in the .htaccess but not wrapped in #BEGIN WordPress - so when your local wp wrote to the file, it appended the rules instead of replacing them. – TheDeadMedic Sep 9 '14 at 13:04
  • Its simple, just log into phpmyadmin and in your database under wp-option.serach for %postname% and delete it just. thanks – umad Mar 12 '17 at 6:47
-1

enter image description here

you have just choose the plain option

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.