0

I had a site setup on old-domain.com, which used the database old_db. Recently, we had to migrate our website to a new server and domain, new-domain.com which uses the database new_db.

I installed a fresh copy of wordpress to the new server, and using the wordpress import tool I was able to import all my posts to the current setup.The images did not copy over, so I simply copied over the wp-content/uploads folder to the new setup, and fixed the image urls using the plugin Search And Replace

Now the issue is, I have all posts appearing proper with images and everything. Everything except Featured Images. The site is not showing any featured images whatsoever. I was told that I need to copy over the postmeta data from old database to new one in order to correctly link them.

Both databases are on the same server. Any help would be hugely appreciated.

  • Are the post IDs identical? – fuxia Sep 6 '14 at 14:00
  • why didn't you just imported the old_db? – Tomás Cot Sep 6 '14 at 14:02
0

It's even easier than what you did. . Copy the entire wp structure from the old server to the new, mysql backup the database with creates enabled and import to the new database (preferably blank) . Then just edit the wp configuration file for the new locations of everything (including database name) . I have done this hundreds of times... Never fails. . And I have also done this moving to entirely different hosts, servers, database etc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.