0

I have a site that's been going for about 4 years with several hundred pages. I've had strange problems when accessing the Pages section (to choose a page for editing) and while in Page editing. These have been resolved (up until now) by deactivating plugins down to the bare minimum (three that are essential for the user experience), then working on page creation or editing, then reactivating plugins.

The symptoms were two-fold:

Pages - this showed up totally blank; could not see any pages listed

Individual page editing (if I used the Edit Page option in the admin bar) - the page contents would be white, although I could use my mouse to select text in this area (it would highlight, showing it was there) - and the lower section would only show a couple of the panels (it would stop loading the page)

Today I reached the point where I had errors even if I deactivated all plugins, so I need some urgent help.

I did a cleanup on the database which pared it down from 93 mb to 58 mb (removing page revisions, optimizing database tables, etc.) and now I can edit pages as long as I deactivate all plugins. However, I'm concerned that the problem will get worse, and that I won't be able to do any page creation or editing at all.

At this point, when I'm only loading two plugins (the very bare minimum for users to be able to navigate the site and watch videos - EmbedIt and JC Submenu) I'm getting the following error message when I access the Pages section of the admin area:

Fatal error: Out of memory (allocated 147587072) (tried to allocate 72 bytes) in /homepages/30/d364769427/htdocs/acbestpractices/wp-includes/meta.php on line 778

If anyone has any ideas for what I can do to fix the issue, I'd be most grateful. I will also appreciate referrals to someone who can troubleshoot and fix this for a reasonable consulting fee; feel free to offer your own services if appropriate.

0

You are using too many static pages. Pages are hierarchical and wordpress doesn't handle page that well. The same goes for Custom Post Type with hierarchical option set.

The only solution here is to ask your host to increase your RAM size. That will solve the problem for now.

But if you continue to add too many pages again, you are again to hit the memory limit someday again. You have to use post rather than page whenever you can. If you really need page for all your content than I must say that wordpress is not the right thing for your need.

  • Sakibmoon - Thanks for taking the time to post a possible answer. This is a membership site with training videos, and they are carefully organized into static pages for a reason. I have JC Submenus set up so that all of the lessons are available in the menus from the hierarchical relationships (individual lessons are children of module pages, and thus are listed in submenus). I know that there are some huge sites that use WordPress, I can't imagine that 426 pages is an issue. The error goes away when I turn off plugins, so I think it might be a plugin conflict. – Eric Bobrow Aug 18 '14 at 16:05
  • Further updates: the problem got worse, so even without plugins I cannot open up the Pages section in the back end (I get a Fatal Memory Error). I migrated the site to my computer and it runs fine, and also tested migration to an account on WPEngine and it also works nicely. I went back to my 1and1 account and tested a migration to a new directory and temporary domain, but had the same errors, so it seems to be a host-specific configuration issue. I have opened a ticket with 1and1 and will see whether they can resolve it, now that I've isolated the issue (not a plugin conflict). – Eric Bobrow Aug 24 '14 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.