3

My wife has a wordpress 3.9.2 site that has a ton of images spread across many galleries. Many of those galleries though, have hundreds of images. This is partly managed by the Paginated Effects Gallery plugin, which breaks the galleries up into 15 image pages. On one particular gallery page, which has more images than any other, after a recent update she has noticed that if more images are added to the gallery they do not always show up.

Note: This is NOT using NextGEN gallery (and she would prefer not to switch to it).

If we manually enter the Database IDs of the images into the [gallery ...] shortcode all of them will show up on the rendered page but nothing after image 995 will show up in the visual editor. It is not a specific image as if I move images to be before the current image #995 it just pushes everything past the new 995 out of the visual editor view. Though they stay in the shortcode and remain visible on the rendered page.

However, if we use the visual editor to add images, it works initially. Images after 995 show up on the rendered page and the editor. But, if we go back and add more, all those previously after 995 are replaced with the new ones, including if you look in the text view at the numbers in the gallery shortcode.

So, clearly, if it's in the gallery shortcode it will show up on the rendered page no matter what. But the visual editor seems to not be able to show or add anything past 995 without overwriting the images previously in those spots.

Unfortunately, the only real way to get those database IDs is with the visual editor :(

I have not been able to find anything that says there is a max number of images you can have in one gallery. If it was right at 1000 I would just assume it was a hard limit. But 995 seems very weird.

We have disabled ALL plugins, restored from old DB backups, created a new page and copied that gallery's code into it... all with the same result.

Anyone have an idea of what could be going on here?

NOTE: This problem STILL occurs regardless of the Paginated Effects Gallery plugin being enabled or not. I have already confirmed it still happens without ANY plugins enabled.

  • IF you can enable debuggin in your wp-config with this line: define('WP_DEBUG', true);. The problem could be related to the massive amount of images you are trying to load. Also, check the site's error logs. – Tomás Cot Aug 15 '14 at 1:31
  • Good Call. I tried, but it generated no errors (I also enabled WP_DEBUG_LOG). – Adam Haile Aug 15 '14 at 1:42
  • Any Javascript Errors during this process? – birgire Aug 15 '14 at 9:58
  • You would think. But no :( – Adam Haile Aug 15 '14 at 11:20
  • 1
    ps: I just want to mention that the default value of max-input-vars is 1000. – birgire Aug 19 '14 at 15:40
1

You have a limit inside an script and you should change some values to adapt your needs:

jQuery....
//user settings
var thumbsPerPage = 15;
var maxPaginatedLinks = 200;
var hideEffect = "drop";
var showEffect = "drop";
var effectSpeed = "slow";
var count = 1;  
//handles multiple galleries on page
var galleryCount = $( "[id^=gallery-]" ).each( function()
var galleryId = "#" + $( this ).attr( "id" ) + " "; 
  • 1
    That's part of the Paginated Effects Gallery plugin and the problem still happens with that plugin disabled. – Adam Haile Aug 13 '14 at 0:19
0

There are two plausible answers.

  1. There is a good chance this is a restriction on the wordpress site settings.

    In multisite this is in:

    Network -> Settings:

    Upload Settings

    Site upload space: [checkbox] Limit total size of files uploaded to [xxx]MB. Default is 50MB.

    Unchecking this or increasing the limit should solve the issue. The side affect of this setting is it would bump off the images which was one of your side effects.

  2. Less likely but check with your hosting provider about your disk space. In that case you would not get any wordpress errors, but the file would not get written to disk if it is out of space. They should have an admin login where you can check your disk space, or just contact them and ask.

0

Still never found a solution that actually fixed the problem. In the end, my work-around was to break each gallery into sub-galleries of less than 200 images and then use the tag to paginate the main page.

This avoided the 995 file limitation as well as vastly improved performance since it only ever tried to load a couple hundred images.

Not ideal, but probably best.

Would still be nice if I knew why it broke in the first place...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.