0

I am using ifttt to sync my wordpress blog with my blogger site, and there is a problem of auto-formatting on wordpress's side. It likes inserting <br> everywhere when exporting posts. For example, a list on wordpress looks like this:

enter image description here

After syncing, the list looks like this on blogger:

enter image description here

Leaving the syncing scenario aside, Wordpress does this to its own posts, too. I had to disable the wpautop function in wp-include/formatting.php to prevent it from inserting those annoying <br> tags. But I don't know which function to disable in the current case. If possible I would like to disable all forms of autoformatting once and for all, because I always use html for markup and there is no need for WP to reformat for me at all.

  • See this link - wordpress.stackexchange.com/questions/130075/… – WisdmLabs Jul 27 '14 at 17:52
  • I did something more radical than that already: I commented out the whole wpautop function. WP still inserts <br> when posting contents on blogger. – qed Jul 27 '14 at 18:16
  • Have you tried remove_all_filters( 'the_content' ); and remove_all_filters( 'the_excerpt' ); ? – Douglas.Sesar Jul 28 '14 at 1:20
  • Where should I put these two commands? Thanks! – qed Jul 28 '14 at 3:00
  • Anyways, I have put these two lines into wp-settings.php, haven't seen any effect yet. – qed Jul 28 '14 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.