0

I'm having an issue debugging why the plugin I'm creating keeps displaying the error You need to upgrade your database as soon as possible....

The work I've done so far has been on a remote dev site, and everything seems to work fine there - with no errors at all. I decided to test what would happen when I throw the plugin into a different environment to see if it would still work fine. Bare in mind that both versions of WordPress are 3.9.1. The plugin has remained the same, but the servers are different. The only other different thing between the two is one is a multi-site (the original dev site), and the other is just a standard WP install.

The first issue I resolved, which was a problem within the way I was creating new tables. For some reason replace as a field name was fine on the dev site, but on the vps it wasn't. Possibly due to different versions of MySQL.

I was wondering if there is a way to debug what is happening? Why would the database need upgraded?

1

First, you need to to find out what your current version of MYSQL...

WordPress requires MySQL 5.0 or greater

Since its a VPS, I'm assuming its a linux installation. Just type

mysql -V

on the command line and it will return your MYSQL version.

If the version is compatible with wordpress, this message may be a "plugin/theme related" message. Look at your plugins and themes and see if any of them have a specific MySQL requirement.

  • You would be correct in thinking it is a linux box, here's the output of that command: mysql Ver 14.14 Distrib 5.5.38, for Linux (x86_64) using readline 5.1 – hazrpg Jul 24 '14 at 17:47
  • It's compatible with wordpress. This means you're error must be coming from a plugin/script... If you google, "You need to upgrade your database as soon as possible..." you get a snippet example on how to create an admin message. Can you check your functions.php if it has this snippet? – lartan Jul 24 '14 at 17:50
  • If you mean the one found here: catswhocode.com/blog/… then yes I have part of that code function showMessage(), but I don't have the one that says the message You need to upgrade your database as soon as possible... which is function showAdminMessages(). – hazrpg Jul 24 '14 at 17:55
  • 1
    You've narrowed it down to plugin related then. I don't think its an Official WordPress Error code. If I were in your shoes, at this point I'd do a string search for "You need to upgrade your database as soon as possible..." on all files in the plugins folder to see which files have it. :) – lartan Jul 24 '14 at 17:58
  • 1
    I know the feeling. Something like this happens to me when I code for hours on end. Glad you found it! – lartan Jul 25 '14 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.