6

I recent migrated my site from Godaddy to Webfaction. On migration, I get this error:

Upload folder is not writable. Export and file upload features will not be functional.

Naturally, I check the permissions of the folder - and they are correct. Just to be safe, I changed it recursively to "777" (as a test, not permanently), and I still cannot upload images.

How can I troubleshoot this issue?

  • I had to run stat -c %a /apps/wordpress/wp-content/uploads/ and then chmod -R 775 /apps/wordpress/wp-content/uploads/ – Ryan Nov 23 '19 at 19:00
  • Very simple, go to youe WB dashboard sitting - media - past the defult (wp-content/uploads) then press SAVE – Abdelrahman H Jun 24 at 6:35
5

That's a server permission problem. According to the WP docs:

Any file that needs write access from WordPress should be owned or group-owned by the user account used by the WordPress (which may be different than the server account). For example, you may have a user account that lets you FTP files back and forth to your server, but your server itself may run using a separate user, in a separate usergroup, such as dhapache or nobody. If WordPress is running as the FTP account, that account needs to have write access, i.e., be the owner of the files, or belong to a group that has write access. In the latter case, that would mean permissions are set more permissively than default (for example, 775 rather than 755 for folders, and 664 instead of 644).

From http://codex.wordpress.org/Changing_File_Permissions

How can I troubleshoot this issue?

Ask Webfaction. Sounds like they need to give you the ability to chmod files/folders or they need to do it for you.

And, FYI, search first for a common issue like permissions; there are many answers already on WP Dev.

| improve this answer | |
  • Thanks, now that you mention it, it may be a groups issue. – Zach Russell Jul 22 '14 at 15:43
  • I reached out to web faction and they have no clue either. I do sysadmin work for several websites, hosting load balanced WordPress instances, this isn't simply a permissions/groups issue. Any other ideas as to what I can do @songdogtech – Zach Russell Jul 23 '14 at 21:33
3

Upload folder is not writable. Export and file upload features will not be functional.

This specific error string comes from Gravity Forms and not WordPress itself.

Go to Settings → Media and check the value for "Store uploads in this folder" is correct. Using the default of wp-content/uploads will remove the error as long as that directory has the correct permissions set.

| improve this answer | |
1

If you are using WordPress multisite, I found this to be the solution.

WordPress multisite's "Upload Path" should be set to a server-relative path (e.g. /home/serveraccountname/public_html/wp-content/uploads).

The "Upload URL Path" should be the URI (e.g. http://example.com/wp-content/uploads).

Ignore the /sites/1/ fragment for sub-sites - WordPress will add these automatically.

| improve this answer | |
1

This may work for certain scenarios. The error does occur if you have exceeded your space limit with your host provider

| improve this answer | |
0

I had also migrated a WordPress site, and encountered this same problem.

After much digging, I realised that the hosting account name had changed As the Wordpress upload path includes the hosting account folder this needs to be edited

Wordpress stores the upload path in the wp_options table in "upload_path" /home/hosting account name/public_html/wp-content/uploads

Edit the field with phpMyAdmin and all fixed ;)

Hope this helps you

Pete Cornish

| improve this answer | |
0

I solved this problem by doing following:

Open myphpadmin through your cpanel and open your database.

Select option table

Find row of named as upload_path and click edit

Delete the value and hit save

| improve this answer | |
0

Changing the url on the WP settings > Media link will correct this. Go to the section "Store uploads in this folder", and ensure the url matches the correct location of your uploads folder.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.