I have tried all recommendations from here but none solves my issue. I have a couple of wordpress installations on a local machine running Win 7 and wamp 2.4 and none of them writes in the debug.log file or even display the errors in the page.

I have set the following in the wp-config.php:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);

I have manually created an empty file named debug.log in the wp-content directory with full permissions for everyone.

My php.ini settings are:

error_reporting = E_ALL
display_errors = On
display_startup_errors = On
log_errors = on
log_errors_max_len = 1024
ignore_repeated_errors = Off
track_errors = On
html_errors = On
error_log = "C:/wamp/logs/php_error.log"

The only way to debug is to use one of the available plugins but they are useless when I'm getting the white screen.

  • Check: C:/wamp/logs/php_error.log and try the example config in the Debugging Codex. May I also recommend Aptana Studio 3 to help debug your PHP.
    – eyoung100
    Jun 24, 2014 at 14:41
  • My config is exactly like the recommended in Codex and both logs, xamp's php_error.log and wp's debug.log are empty. Will try Aptana.
    – vadims
    Jun 24, 2014 at 15:25
  • Taking a look at the gist: paranoia-config.php by @kaiser might give you some additional information. Jun 24, 2014 at 15:33
  • 1
    Do you see errors with WP_DEBUG_DISPLAY enabled? What does ini_get('error_log') contain after load (at init or later)?
    – Rarst
    Jun 24, 2014 at 15:43


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.