4

I want to move my Wordpress blog to a different server. I dumped the database from the old server and imported it to the new server, and set up the new database details in wp-config.php. I can log in to the admin console online, and I can see all the posts, but if I go to the front page of the blog, the page is just blank. There are no errors in the apache logs. Does anyone have any idea what might be going on?

2

Easiest thing to do is enable debugging to find the php error that is causing the white screen in the theme on the front end and fix that; it's probably a missing file, or the error will point to a incompatible plugin. See https://codex.wordpress.org/Debugging_in_WordPress

Or, toggle the theme to the default theme and check the front end; rename the plugins folder to disable all plugins, reload admin and name it back to plugins; and reset permalinks.

  • My theme broke when upgrading from Ubuntu 12.04 to 14.04. Although I didn't have the default theme in use, it did come with Ubuntu package. Thanks – jippie Dec 26 '15 at 16:06
2

My experience with blank home page.

Sometimes when you are migrating your page you can get blank home page.

I found the problem with the home page not displaying from the base URL. it was because there was a default.html file in the root directory. The old hosting server must had set the order to look for start files to PHP extension as the first default so it ignored the default.html file in the root directory and loaded index.php.

The new hosting server must have the default extension it looks for as an .HTM or .HTML file and was loading the blank default.html file first. Once I deleted the blank default.html file the hosting server started loading the index.php file and displayed the WordPress home page.

BR

  • Thanks, you made my day. I had this problem when migrating from Bluehost to Dreamhost. Deleting a default.html file that was present for some reason (probably an old file) solved it. – Erwin Mayer Jan 17 '17 at 17:26
2

Go to http://example.com/wp-admin/options.php

Look for both the Site URL and Blog URL fields, and make sure the domain name is correct.

1

Please turn on website debug mode with below code in wp-config.php file and check the error on blog page:

define( 'WP_DEBUG', true );
0

In case you are using Permalinks, try re-setting them in the Settings > Permalinks page.

0

I had this issue and confirmed the database was connecting properly but the homepage still showed up blank (empty <body></body> elements).

I resolved it by correcting my paths for WP_SITEURL, WP_CONTENT_DIR and WP_CONTENT_URL in wp-config.php.

  • WP_SITEURL should point directly to the WordPress root folder (one that includes 'wp-admin', 'wp-includes', etc)
  • WP_CONTENT_DIR should point directly to the 'wp-content' folder (one that includes 'plugins', 'themes', 'uploads', etc).

Note: These should be set toward the top of wp-config.php, above the lines for 'Absolute path to the WordPress directory' and 'Sets up WordPress vars and included files'.

Example for wp-config.php:

define('WP_SITEURL', 'http://' . $_SERVER['SERVER_NAME'] . '/wordpress');
define('WP_HOME',    'http://' . $_SERVER['SERVER_NAME']);
define('WP_CONTENT_DIR', $_SERVER['DOCUMENT_ROOT'] . '/wordpress/wp-content');
define('WP_CONTENT_URL', 'http://' . $_SERVER['SERVER_NAME'] . '/wordpress/wp-content');
0

I hope this helps:

  1. If the page is blank, there is an error. It is just being suppressed. Add to wp-config.php: define('WP_DEBUG',true);
  2. I own hundreds of WordPress sites and I have found I enjoy using a tool when possible. Duplicator or Backup Buddy work great for what you are trying to do.

I am new to this site, so if this answer is at all helpful, please let me know.

0

I think The Active Theme Files are missing. Thats why homepage is showing blank.

Solution: Move wp-content folder over from old server to new server :)

Thanks

0

In my case the issue was wp-admin folder.

I had installed WordPress using one-click in Cpanel. Then I used FTP to upload my website. As the folders created by WordPress automatic setup were already present, I had 2 wp-admin, 2 wp-content folders. Also, I mistakenly uploaded the website in wp-admin. When I moved the files out of wp-admin the site worked instantly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy